Opened 10 years ago

Closed 10 years ago

#6687 closed defect (invalid)

Mythfrontend Segfaulting if channel-change failing

Reported by: eric.bosch@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythfrontend sometimes segfaults when attempting to change channel using firewire device. Attached is gdb.txt and myth.log from the event. I am running 20788 Head SVN with Gentoo 2.6.30-r2 kernel, nVidia 9800 card.

Attachments (2)

gdb.txt (40.4 KB) - added by eric.bosch@… 10 years ago.
gdb output of backtrace
myth.log (81.7 KB) - added by eric.bosch@… 10 years ago.
Log file of mythfrontend.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by eric.bosch@…

Attachment: gdb.txt added

gdb output of backtrace

Changed 10 years ago by eric.bosch@…

Attachment: myth.log added

Log file of mythfrontend.

comment:1 Changed 10 years ago by danielk

Milestone: 0.22unknown
Status: newinfoneeded_new

Eric, I don't see why it would crash there. So that really leaves memory corruption which is generally means running a tool like valgrind. But the events leading up to this in myth.log are interesting. Can you reproduce this? If so please reproduce with "-v network,extra" and post both the frontend and backend logs, this may be fixable without slogging through valgrind logs.

comment:2 Changed 10 years ago by eric.bosch@…

Sorry, I can't reproduce this at this point. I don't think Ive been having that exact problem for at least some time. I'm running current trunk, and was having some unusual segfaults, so I recompiled glibc, all of QT, and kdelibs, and that now seems to have stabilized things a bit more. Thanks.

comment:3 Changed 10 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

It's possible this is some memory overwriting bug that was fixed, or a problem with Eric's machine, or something else. But since it can't be reproduced anymore and we don't know of any particular changeset that fixed it I'm marking this invalid.

Note: See TracTickets for help on using tickets.