Opened 10 years ago

Closed 10 years ago

#6704 closed defect (invalid)

Fatal Error at /usr/share/mythtv/mythweb/objects/Database/Query/mysql.php, line 83: SQL Error: Table 'mythweb_sessions' already exists [#1050]

Reported by: anonymous Owned by: xris
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Backtrace:

datetime: 2009-07-09 23:49:51 (CEST) errornum: 256

error type: User Error

error string: SQL Error: Table 'mythweb_sessions' already exists #1050

filename: /usr/share/mythtv/mythweb/objects/Database/Query/mysql.php

error line: 83

==========================================================================

Backtrace:

file: /usr/share/mythtv/mythweb/objects/Database/Query/mysql.php line: 83

class:

function: trigger_error

type: args: Array

(

[0] => SQL Error: Table 'mythweb_sessions' already exists #1050 [1] => 256

)

file: /usr/share/mythtv/mythweb/objects/Database.php line: 261

class: Database_Query_mysql

function: execute

type: -> args: Array

(

[0] => Array ( )

)

file: /usr/share/mythtv/mythweb/includes/db_update.php line: 37

class: Database

function: query

type: -> args: Array

(

[0] => CREATE TABLE mythweb_sessions (

id VARCHAR(128) PRIMARY KEY NOT NULL DEFAULT "", modified TIMESTAMP, data BLOB NOT NULL DEFAULT "", INDEX (modified)

)

)

file: /usr/share/mythtv/mythweb/includes/init.php line: 39

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/includes/db_update.php

)

file: /usr/share/mythtv/mythweb/mythweb.php line: 20

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/includes/init.php

)

==========================================================================

$_SERVER: Array (

[REDIRECT_STATUS] => 200 [HTTP_HOST] => 127.0.0.1 [HTTP_USER_AGENT] => Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.11) Gecko/2009060310 Ubuntu/8.10 (intrepid) Firefox/3.0.11 [HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 [HTTP_ACCEPT_LANGUAGE] => de-de,de;q=0.8,en-us;q=0.5,en;q=0.3 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_KEEP_ALIVE] => 300 [HTTP_CONNECTION] => keep-alive [PATH] => /usr/local/bin:/usr/bin:/bin [SERVER_SIGNATURE] => <address>Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch Server at 127.0.0.1 Port 80</address>

[SERVER_SOFTWARE] => Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch [SERVER_NAME] => 127.0.0.1 [SERVER_ADDR] => 127.0.0.1 [SERVER_PORT] => 80 [REMOTE_ADDR] => 127.0.0.1 [DOCUMENT_ROOT] => /var/www [SERVER_ADMIN] => webmaster@localhost [SCRIPT_FILENAME] => /var/www/mythweb/mythweb.php [REMOTE_PORT] => 54620 [REMOTE_USER] => mythtv [AUTH_TYPE] => Digest [REDIRECT_URL] => /mythweb/ [GATEWAY_INTERFACE] => CGI/1.1 [SERVER_PROTOCOL] => HTTP/1.1 [REQUEST_METHOD] => GET [QUERY_STRING] => [REQUEST_URI] => /mythweb/ [SCRIPT_NAME] => /mythweb/mythweb.php [PHP_SELF] => /mythweb/mythweb.php [PHP_AUTH_DIGEST] => username="mythtv", realm="MythTV", nonce="ATxM1UxuBAA=9d61fdf37f2ed237fc5fff03a34d9c9ee9515059", uri="/mythweb/", algorithm=MD5, response="a393fc0b06fc64c4900ade8fd5147d5d", qop=auth, nc=00000001, cnonce="bb61551ca1b0346a" [REQUEST_TIME] => 1247176191 [argv] => Array ( ) [argc] => 0 [STATUS] => 200 [URL] => /mythweb/

)

Change History (1)

comment:1 Changed 10 years ago by xris

Resolution: invalid
Status: newclosed

Not a bug. You've somehow managed to corrupt the information in your database to make it think that the schema is older than it really is.

Note: See TracTickets for help on using tickets.