Opened 10 years ago

Closed 10 years ago

#6709 closed defect (fixed)

Changeset [20797] breaks configure on FreeBSD

Reported by: Raymond Wagner <raymond@…> Owned by: Janne Grunau
Priority: critical Milestone: 0.22
Component: Ports - *BSD Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The configure script will not automatically search through /usr/local/include causing configure to fail to pick up Lame (and likely other dependencies). Normally, this is fixed just with a '--extra-cflags=-I/usr/local/include --extra-ldflags=-L/usr/local/lib', however the change to configure in [20797] now results in:

-D_ISOC99_SOURCE: not found
WARNING! An unknown C compiler flag in: "-I/usr/local/include". Option(s) will be ignored.

I'm looking through the diff to try to figure out what the problem is.

Attachments (1)

config.ep (86.5 KB) - added by Raymond Wagner <raymond@…> 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Raymond Wagner <raymond@…>

Attachment: config.ep added

comment:1 Changed 10 years ago by Raymond Wagner <raymond@…>

Configure runs fine if additional flags are added to the environment rather than through the configure line.

env CFLAGS=-I/usr/local/include LDFLAGS=-L/usr/local/lib ./configure  ....

comment:2 Changed 10 years ago by Dibblah

Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned

At the point where check_ecflags is run, cc is unset. I am not sure of the reason for this, but this particular error appears to be indicative of a deeper issue.

comment:3 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: assignedclosed

(In [20888]) add C++ compiler sanity check. Fixes #6709

extra cflags and cxxflags can only checked after C and C++ compiler are set i.e. after the command line parse loop. So we add the flags without checking in the loop and run compiler sanity checks early. Adds a hint to check extra flags if the compiler checks fail.

Note: See TracTickets for help on using tickets.