Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6711 closed patch (fixed)

Update win32-packager.pl to use Qt4 binary dist

Reported by: Jeff Lu <jll544@…> Owned by: Nigel
Priority: minor Milestone: unknown
Component: Ports - Windows Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Update to the win32 packager script attached, with the major change of using Trolltech Qt4.5 binaries instead of compiling from source, thereby cutting overall build time by a few hours and hopefully reducing user-reported problems.

Other changes: update gcc to 4.2.4 to appease ffmpeg, update source download locations/versions, default compile_type to profile for better performance, default cpu_arch to p4 for wider compatibility and fewer user-reported crashes, fix libvisual and SDL installs for potential plugin porting.

Tested with trunk r20847 on XP and Vista 32bit.

Attachments (1)

6711-w32packager.patch (27.1 KB) - added by Jeff Lu <jll544@…> 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Jeff Lu <jll544@…>

Attachment: 6711-w32packager.patch added

comment:1 Changed 11 years ago by davidbuzz@…

Nigel, Looks good to me, please commit when you have a chance! David/Buzz?.

comment:2 Changed 11 years ago by anonymous

This worked for me with 20696 (to match existing linux install), tried to run again with 20856 and it failed when turning on the option to build a package:

COMMENTS:------------------------------ COMMENTS:Install innosetup - install ISTool, COMMENTS:------------------------------

too many parameters in cause->event declaration (file C:/Program Files/Inno? Setup 5/iscc.exe exec C:\MSys\1.0\sources\isetup-5.2.3.exe comment Install innosetup - install ISTool, ISSP, AND encryption support.) at win32-packager.pl line 2240.

The version doesn't matter--my first build was without "-k" this was with it--I was just mentioning that as I was able to get a build of an older version (that probably would've failed with "-k"). Trying again without -k as I type this.

comment:3 Changed 11 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [20872]) Use Qt 4.5 download. Closes #6711

comment:4 Changed 11 years ago by Steltek

Please change line 706 from:

fetch => 'ftp://ftp.qtsoftware.com/packages/qt/source/'.

to:

fetch => 'ftp://ftp.qtsoftware.com/qt/source/'.

The download URL does not work with the 'packages' in the path. (I'd submit a patch, but I don't have the tools to generate one at hand.

Note: See TracTickets for help on using tickets.