Opened 11 years ago

Closed 11 years ago

#6735 closed defect (duplicate)

MythMusic with libvisual compile error on Fedora 11

Reported by: otto at kolsi dot fi Owned by: stuartm
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Following error occurs while compiling MythMusic with libvisual support in Fedora 11:

compiling mainvisual.cpp
In file included from mainvisual.cpp:34:
visualize.h:35:32: error: missing binary operator before token "double"
compiling newsarticle.cpp
compiling newsdbutil.cpp
compiling dbcheck.cpp
compiling main.cpp
make[2]: *** [mainvisual.o] Error 1
make[2]: Leaving directory `/mnt/myth/trunk/mythplugins/mythmusic/mythmusic'
make[1]: *** [sub-mythmusic-make_default] Error 2
make[1]: Leaving directory `/mnt/myth/trunk/mythplugins/mythmusic'
make: *** [sub-mythmusic-make_default] Error 2
make: *** Waiting for unfinished jobs....
$ rpm -qa |grep libvisual
libvisual-devel-0.4.0-8.fc11.i586
libvisual-0.4.0-8.fc11.i586
$ gcc --version
gcc (GCC) 4.4.0 20090506 (Red Hat 4.4.0-4)
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Configuration output:

        qmake          /usr/bin/qmake-qt4

        MythArchive    plugin will not be built
        MythBrowser    plugin will be built
        MythFlix       plugin will not be built
        MythGallery    plugin will be built
        MythGame       plugin will not be built
        MythMusic      plugin will be built
        MythNews       plugin will be built
        MythVideo      plugin will be built
        MythWeather    plugin will be built
        MythZoneMinder plugin will be built
        MythMovies     plugin will not be built
        OpenGL         support will be included in MythGallery
        EXIF           support will be included in MythGallery
        OpenGL         support will be included in MythMusic
        libvisual      support will be included in MythMusic
        FFTW v.3       support will be included in MythMusic
        SDL            support will be included in MythMusic
        AAC            support will not be included in MythMusic

Change History (4)

comment:1 Changed 11 years ago by otto at kolsi dot fi

This happens also with libvisual disabled, so it's a general MythMusic compilation problem in F11?

comment:2 Changed 11 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Dupe of #6414?

Try running mythplugins configure with --disable-fftw. I saw the same/similar problem last week when trying to build with fftw enabled. My patch on #6696 was committed in r20832 to allow fftw to be completely disabled.

comment:3 in reply to:  2 Changed 11 years ago by otto at kolsi dot fi

Replying to Nick Morrott <knowledgejunkie (at) gmail (dot) com>:

Dupe of #6414?

Try running mythplugins configure with --disable-fftw. I saw the same/similar problem last week when trying to build with fftw enabled. My patch on #6696 was committed in r20832 to allow fftw to be completely disabled.

Yes, this is dupe of #6414 and should be closed. Compile works with --disable-fftw

comment:4 Changed 11 years ago by Dibblah

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.