Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6737 closed patch (fixed)

CPU auto-detection broken in the configure script

Reported by: mythtv@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

CPU auto-detection is still broken after [20893]

The attached patch fixes this and also adds support for AMD Athlon MP and Intel Core i7 processors.

Additionally, the processor detection error message is displayed if there is no match for the $processor string.

Attachments (1)

CPU_auto-detection.patch (1.4 KB) - added by mythtv@… 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by mythtv@…

Attachment: CPU_auto-detection.patch added

comment:1 Changed 10 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned

I'll add the processor types and the error message if nothing can be found

The if condition for the $processor based optimization is correct and works as intended. Please explain why you think it is broken.

comment:2 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: assignedclosed

(In [20952]) Adds Intel i7 and Athlon-MP to proc_opt based cpu detection, Closes #6737

comment:3 in reply to:  1 Changed 10 years ago by anonymous

Replying to janne:

I'll add the processor types and the error message if nothing can be found

The if condition for the $processor based optimization is correct and works as intended. Please explain why you think it is broken.

Sorry, I didn't correctly understand the --enable-proc-opt option

Note: See TracTickets for help on using tickets.