Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#6771 closed defect (fixed)

MythGallery fails to show EXIF information (QPainter)

Reported by: otto at kolsi dot fi Owned by: stuartm
Priority: minor Milestone: 0.24
Component: Plugin - MythGallery Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

MythGallery fails to show EXIF information for photos in one particular machine. EXIF info can be seen on another frontend just fine. One difference is that machine which has problems has older card (nVidia 5200) and older drivers (if this has anything to do with it).

When problem occurs, following is printed to logs:

QPainter::begin: A paint device can only be painted by one painter at a time.
QPainter::initFrom: Painter not active, aborted
QPainter::end: Painter not active, aborted

The grey background image for EXIF info is shown but there is no EXIF texts.

Change History (6)

comment:1 Changed 9 years ago by beirdo

Owner: changed from Isaac Richards to beirdo
Status: newassigned

comment:2 Changed 9 years ago by beirdo

Status: assignedinfoneeded

I can't reproduce this with trunk [25660]. Is this still a problem, and if so, what version are you running?

comment:3 Changed 9 years ago by beirdo

Status: infoneededassigned

Confirmed on IRC that the problem remains for the user with trunk. He's configuring with:

./configure --previous
Options:  --qmake=/usr/lib/qt4/bin/qmake --disable-audio-jack --disable-joystick-menu 
--disable-firewire --disable-ivtv --disable-v4l --disable-hdhomerun --disable-iptv 
--enable-dvb --enable-opengl-vsync --enable-opengl-video --disable-xvmc --disable-mheg 
--enable-silent_cc --compile-type=debug

Just in case this has any effect on the problem.

Last edited 9 years ago by beirdo (previous) (diff)

comment:4 Changed 9 years ago by beirdo

Owner: changed from beirdo to stuartm

comment:5 Changed 9 years ago by stuartm

Milestone: unknown0.24
Resolution: fixed
Status: assignedclosed

(In [25780]) Always explicitly end painting with a QPainter instance when we're finished. Fixes the EXIF display bug. Fixes #6771

Please re-open if you can still reproduce the bug following this commit.

comment:6 Changed 9 years ago by otto at kolsi dot fi

This working fine now, thanks!

Note: See TracTickets for help on using tickets.