Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6790 closed defect (fixed)

After exiting the guidegrid the theme background remains visible

Reported by: Christian Güdel <cg@…> Owned by: stuartm
Priority: minor Milestone: 0.22
Component: MythTV - User Interface Library Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

{{mythbox ~ # mythfrontend --version Please include all output in bug reports. MythTV Version : exported MythTV Branch : trunk Library API : 0.22.20090727-1 Network Protocol : 45 QT Version : 4.4.2 Options compiled in:

linux profile using_oss using_alsa using_backend using_dvb using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg}}

When I enter Live TV (this doesn't seem to happen with a recording), then enter the program guide and then exiting the program guide, sometimes the theme background remains visible and the video seems to play "behind" it. After pressing exit (escape) the second time, I'm back at the main menu.

The bug isn't always reproducible here, I've attached a log with -v most, don't know if it helps though. It does not happen in the watch recordings playback.

Doesn't seem to depend on the theme (does happen with blue and G.A.N.T and Terra)

Attachments (2)

fe_log.txt (224.6 KB) - added by Christian Güdel <cg@…> 10 years ago.
tvwin_fixes.diff (5.8 KB) - added by stuartm 10 years ago.
Possible fix

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Christian Güdel <cg@…>

Attachment: fe_log.txt added

comment:1 Changed 10 years ago by stuartm

Component: MythTV - GeneralMythTV - User Interface Library
Milestone: unknown0.22
Owner: changed from Isaac Richards to stuartm
Status: newaccepted
Ticket locked: set

Known issue and a solution is on the way.

Changed 10 years ago by stuartm

Attachment: tvwin_fixes.diff added

Possible fix

comment:2 Changed 10 years ago by stuartm

Status: acceptedinfoneeded

Can someone who is seeing this problem, video apparently drawn behind the UI, please test the attached patch?

This isn't a fix for rubbish flash onto the screen just before the video plays normally, that's an unrelated bug.

comment:3 Changed 10 years ago by stuartm

Resolution: fixed
Status: infoneededclosed

(In [21379]) Suspend UI drawing before chromakey is drawn. Unable to test this myself as I couldn't reproduce the bug, but it worked for Daniel. Fixes #6790

comment:4 Changed 10 years ago by stuartm

Ticket locked: unset
Note: See TracTickets for help on using tickets.