Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#680 closed defect (fixed)

F7 signal monitor hangs with DVB HD-3000

Reported by: doug@… Owned by: danielk
Priority: major Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

A windstorm seems to have misaligned my antenna, so I figured this would be a good time to try out the new signal monitor UI. I have dual pcHDTV HD-3000 cards with DVB drivers. But frontend hangs up when I press F7 (it eventually times out and offers to go back to the menu); backend is hosed at this point and requires a restart. This is SVN rev 7932.

I saw a previous reference to this problem, where you (Daniel) requested specific frontend and backend logs, and a backend gdb backtrace. These are (will be soon) attached.

-Doug

Attachments (3)

frontend.log (36.2 KB) - added by doug@… 14 years ago.
frontend -v network log
backend.log (104.4 KB) - added by doug@… 14 years ago.
backendend -v siparser,channel,record log
gdb.log (10.3 KB) - added by doug@… 14 years ago.
backend gdb backtrace

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by doug@…

Attachment: frontend.log added

frontend -v network log

Changed 14 years ago by doug@…

Attachment: backend.log added

backendend -v siparser,channel,record log

Changed 14 years ago by doug@…

Attachment: gdb.log added

backend gdb backtrace

comment:1 Changed 14 years ago by danielk

Milestone: 0.19
Priority: minormajor

I can reproduce this. It's one of the things I've been trying to fix as part of #664, but it deserves it's own ticket.

This is due to #340, so you can roll-back to before the breaking commit of that if you just want to check out the UI.

comment:2 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [7961]) Fixes #680, and fixes #664.

This creates seperate ringbuffers for the signal monitoring stage and the video stage. This also fixes #680, this required the ringbuffer reset flag to be set (which was needed for #664 as well) and for the ringbuffer to be created.

I had this code last week, but it didn't work until after the short video fix Isaac committed in [7958].

comment:3 Changed 14 years ago by danielk

(In [7967]) References #680 and refreneces #664.

Fixes breakage of PVR-250, by using [Create|Switch]LiveTVRingBuffer in the right places. And fixes SwitchLiveTVRingBuffer to work with signal monitoring recorders.

Note: See TracTickets for help on using tickets.