Opened 10 years ago

Closed 10 years ago

#6835 closed defect (fixed)

in 21228 Scan for changes in mythvideo removes all "non storage group videos"

Reported by: tafypz Owned by: Anduin Withers
Priority: major Milestone: 0.22
Component: Plugin - MythVideo Version: head
Severity: high Keywords: mythvideo storage group
Cc: Ticket locked: no

Description

just updated to 21228.

My setup consists of 1 video storage group for single video files (.mpg, .avi etc) then I use a local mount for my dvd iso files on each frontend.

after upgrading to 21228 using "scan for changes" to add a new dvd .iso to my library removed all my dvd iso entries in the db, only leaving the files in the video storage directory.

Change History (4)

comment:1 Changed 10 years ago by robertm

Resolution: invalid
Status: newclosed

This is as intended. You can have Storage Groups (and ultimately we will support *only* Storage Groups) or you can have the local mounts, but we will not be supporting both at once. The recent change to scanning behavior enforces the use of Storage Groups when they exist.

comment:2 Changed 10 years ago by stuartm

Note that support for DVDs in storage groups has been written and will find it's way into trunk hopefully before 0.22

comment:3 Changed 10 years ago by Isaac Richards

Resolution: invalid
Status: closednew

I don't see why this should be an invalid configuration. Reopening.

comment:4 Changed 10 years ago by robertm

Resolution: fixed
Status: newclosed

(In [21229]) Reverts r21206. Closes #6835. Reverts SG scanning changes, we'll see if we can find a solution that works for everyone and prevents duplicate items while we work towards full MythVideo? storage group support. People who see dupe items w/ SG setups can apply this change locally until we get it sorted out.

Note: See TracTickets for help on using tickets.