Opened 10 years ago

Closed 10 years ago

#6850 closed defect (fixed)

Jump error when chaning program in livetv

Reported by: pik Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: MythTV - DVB/ATSC Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Dibblah)

It happens systematically with the same dvb-s channel broadcasting an 1080 HD signal on Hotbird ( HD Suisse, mpeg 2 compressed, qpsk modulated ). After selecting the channel in lifetv I get a jump program error, after the second try mythfrontend freezes and I have to kill it manually. After I restart the problem persists, it tries ti tune to this channel without success and mythfrontend hangs again?

The only way out is to change start channel of the corresponding source ( using mythtv-setup). Looking at mythfrontend output, it seems that it looks for a file that does not exist ( /maxtor_/myth/lifetv/1990_20090815201338.mpg in this case ) which I think is trigering the problem. This only happens with this specific channel that brodcast full HD signals in qpsk mpeg2.

Output of mythfrontend

09-08-15 20:31:44.706 TV: StartPlayer?(0, Watching WatchingLiveTV, main) -- begin 2009-08-15 20:31:44.721 NVP(0): Disabling Audio, params(-1,2,44100) 2009-08-15 20:31:44.733 VideoOutputXv?: XVideo Adaptor Name: 'NV17 Video Texture' 2009-08-15 20:31:44.759 OSD Theme Dimensions W: 640 H: 480 2009-08-15 20:31:44.932 TV: StartPlayer?(0, Watching WatchingLiveTV, main) -- end ok 2009-08-15 20:31:44.932 TV: Changing from None to Watching WatchingLiveTV 2009-08-15 20:31:44.932 TV: State is LiveTV & mctx == ctx 2009-08-15 20:31:44.933 New DB connection, total: 3 2009-08-15 20:31:44.933 New DB connection, total: 4 2009-08-15 20:31:44.935 Using realtime priority. 2009-08-15 20:31:44.935 OpenGLVideoSync() 2009-08-15 20:31:44.956 Connected to database 'mythconverg' at host: 172.19.3.6 2009-08-15 20:31:44.957 TV: UpdateOSDInput done 2009-08-15 20:31:44.958 TV: UpdateLCD done 2009-08-15 20:31:44.985 Video timing method: SGI OpenGL 2009-08-15 20:31:44.985 Connected to database 'mythconverg' at host: 172.19.3.6 2009-08-15 20:31:44.986 TV: ITVRestart done 2009-08-15 20:31:45.008 ScreenSaverX11Private: DPMS Deactivated 1 2009-08-15 20:31:45.057 Loading window theme from /usr/share/mythtv/themes/default/schedule-ui.xml 2009-08-15 20:31:55.273 RingBuf?(/media/maxtor_/myth/lifetv/1990_20090815203153.mpg): Waited 2.0 seconds for data to become available... 2009-08-15 20:31:55.273 Checking to see if there's a new livetv program to switch to.. 2009-08-15 20:31:57.274 RingBuf?(/media/maxtor_/myth/lifetv/1990_20090815203153.mpg): Waited 4.0 seconds for data to become available... 2009-08-15 20:31:57.274 Checking to see if there's a new livetv program to switch to.. 2009-08-15 20:32:01.276 RingBuf?(/media/maxtor_/myth/lifetv/1990_20090815203153.mpg): Waited 8.0 seconds for data to become available... 2009-08-15 20:32:01.276 Checking to see if there's a new livetv program to switch to.. 2009-08-15 20:32:09.279 RingBuf?(/media/maxtor_/myth/lifetv/1990_20090815203153.mpg) Error: Waited 16 seconds for data, aborting. 2009-08-15 20:32:09.279 RingBuf?(/media/maxtor_/myth/lifetv/1990_20090815203153.mpg) Warning: Peek() requested 2048 bytes, but only returning 0 2009-08-15 20:32:09.279 NVP::OpenFile?(): Error, couldn't read file: /media/maxtor_/myth/lifetv/1990_20090815203153.mpg 2009-08-15 20:32:09.279 NVP(0), Error: JumpToProgram? failed. 2009-08-15 20:32:09.279 NVP(0), Error: Unknown recorder error, exiting decoder 2009-08-15 20:32:09.294 ~OpenGLVideoSync() -- closing opengl vsync 2009-08-15 20:32:09.516 TV: Attempting to change from Watching WatchingLiveTV to None 2009-08-15 20:32:09.815 TV: Changing from Watching WatchingLiveTV to None 2009-08-15 20:32:09.835 ScreenSaverX11Private: DPMS Reactivated 1 2009-08-15 20:32:09.836 TV: Attempting to change from None to None 2009-08-15 20:32:09.858 TV: Attempting to change from None to Watching WatchingLiveTV 2009-08-15 20:32:09.858 Using protocol version 46 2009-08-15 20:32:09.859 Spawning LiveTV Recorder -- begin 2009-08-15 20:32:10.539 Spawning LiveTV Recorder -- end 2009-08-15 20:32:10.553 We have a playbackURL(/media/maxtor_/myth/lifetv/1990_20090815203209.mpg) & cardtype(DUMMY) 2009-08-15 20:32:10.557 We have a RingBuffer? 2009-08-15 20:32:10.557 TV: StartPlayer?(0, Watching WatchingLiveTV, main) -- begin 2009-08-15 20:32:10.558 playCtx, Error: Attempting to setup a player, but it already exists. 2009-08-15 20:32:10.558 TV: StartPlayer?(0, Watching WatchingLiveTV, main) -- end error 2009-08-15 20:32:10.558 TV Error: LiveTV not successfully started 2009-08-15 20:32:10.579 ScreenSaverX11Private: DPMS Deactivated 1 2009-08-15 20:32:10.579 ScreenSaverX11Private: DPMS Reactivated 1

Attachments (2)

mythbackendlog (35.7 KB) - added by pik 10 years ago.
mythfrontendlog (38.9 KB) - added by pik 10 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by pik

tested with svn 21269 and kernel 2.6.30

comment:2 Changed 10 years ago by anonymous

Also tested with Kaffeine, works ok, so it's a myth problem

comment:3 Changed 10 years ago by Dibblah

Description: modified (diff)
Status: newinfoneeded_new

Logs from:

mythbackend -v channel,record

Please.

comment:4 in reply to:  3 ; Changed 10 years ago by anonymous

Replying to Dibblah:

Logs from:

mythbackend -v channel,record

Please.

Will post it. It is very strange, scheduled recording works ! The problem seems to be limited to lifetv. I was able to record and watch my recordings. Looks like a video problem.

Changed 10 years ago by pik

Attachment: mythbackendlog added

Changed 10 years ago by pik

Attachment: mythfrontendlog added

comment:5 in reply to:  4 Changed 10 years ago by pik

I have attached the mythbackend and mythfrontend logs. I have started mythbackend with the option -v channel, record. If there is another test I have to do, please let me know, the problem can easily be reproduced.

comment:6 Changed 10 years ago by Shane Shrybman

There are a couple patches on ticket #6612 that might help your problem.

DTV_StartNewFile_debug.diff

LiveTV_DTV_ringbuffer_check_debug2.diff

If either (or both) patches resolve your issue please let us know.

Thanks

comment:7 Changed 10 years ago by Dibblah

Status: infoneeded_newnew

comment:8 in reply to:  6 ; Changed 10 years ago by pik

Replying to gnome42:

There are a couple patches on ticket #6612 that might help your problem.

DTV_StartNewFile_debug.diff

LiveTV_DTV_ringbuffer_check_debug2.diff

Tried these two patches and it did not solve the problem. Also tried the other patches in ticket 6602 during a second round of test but it did not help either. Finaly I tried with a clean database after rescanning the transponder of the channel creating this problem. The problem also persists

comment:9 in reply to:  8 Changed 10 years ago by anonymous

" Also tried the other patches in ticket 6602 during a second round of test but it did not help either."

6612 not 6602 ( typo )

comment:10 Changed 10 years ago by pik

The dvb-s channel HD suisse ( Astra 19.2 E ) for which I am havinv this problem is transmitting in dvb-s and uses h264 and not mpeg2. Sorry for the confusion.

comment:11 Changed 10 years ago by cg@…

HD suisse is broadcasted on Hotbird 13.0°E as a DVB-S channel with MPEG4 video. The problem also exists on cable and the problem didn't exist with 0.21.

comment:12 Changed 10 years ago by Janne Grunau

Owner: changed from danielk to Janne Grunau
Status: newaccepted
Version: unknownhead

comment:13 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

(In [21524]) prevent H264 SEI parsing from consuming the next start code. Fixes #6850, Fixes #6910

patch by: John P Poet < jppoet gmail com >

Note: See TracTickets for help on using tickets.