Opened 10 years ago

Closed 9 years ago

#6853 closed defect (invalid)

Apparent deadlock on playback exit

Reported by: mythtv@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

During video playback, sound suddenly disappears, attempt to exit playback causes deadlock. This issue is intermittent and happens once out of 5-6 videos watched. Video is a recording from HDPVR.

Attaching gdb and then detaching seems to get frontend back to working state.

Attaching frontend log (general,playback,audio logging), and backtrace from gdb.

Sound card: Sound Blaster MP3+ Processor: AMD Athlon(tm) 7750 Dual-Core Processor Video Card: nVidia Corporation D9M-20 9400 GT? (rev a1)

$ mythfrontend --version
Please include all output in bug reports.
MythTV Version   : Unknown
MythTV Branch    : 
Library API      : 0.22.20090804-1
Network Protocol : 45
QT Version       : 4.5.0
Options compiled in:
 linux debug using_oss using_alsa using_pulse using_jack using_backend using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

$ mythbackend --version
Please include all output in bug reports.
MythTV Version   : Unknown
MythTV Branch    : 
Library API      : 0.22.20090804-1
Network Protocol : 45
QT Version       : 4.5.0
Options compiled in:
 linux debug using_oss using_alsa using_pulse using_jack using_backend using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Attachments (2)

frontend.log.gz (23.1 KB) - added by mythtv@… 10 years ago.
Frontend log
backtrace.log.gz (4.7 KB) - added by mythtv@… 10 years ago.
backtrace of all threads

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by mythtv@…

Attachment: frontend.log.gz added

Frontend log

Changed 10 years ago by mythtv@…

Attachment: backtrace.log.gz added

backtrace of all threads

comment:1 Changed 10 years ago by Shane Shrybman

Resolution: invalid
Status: newclosed

Thanks for your report. There have been many fixes relating to HD-PVR material in the last couple of months. Hopefully this issue has been fixed.

If you can still reproduce this problem with current trunk, drop a note to the -dev mailing list asking to re-open this ticket.

comment:2 Changed 10 years ago by Shane Shrybman

Resolution: invalid
Status: closednew

Re-opening for now. Asked reporter to pursue user support for audio issues and to test with latest 0.22-fixes and possibly trunk as well.

comment:3 Changed 9 years ago by mythtv@…

After rebuilding the system on a different set of hardware, I cannot reproduce this anymore. Please close as invalid at your discretion.

comment:4 Changed 9 years ago by robertm

Resolution: invalid
Status: newclosed

Thank you for reporting back.

Note: See TracTickets for help on using tickets.