Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6874 closed patch (fixed)

Fix HDHomerun DVBT support

Reported by: mikeb@… Owned by: Nigel
Priority: major Milestone: 0.22
Component: MythTV - DVB/ATSC Version: head
Severity: high Keywords: hdhomerun dvbt h264
Cc: Ticket locked: yes

Description

Patch addresses the following quirks

  • use auto modulation ("qam64:frequency" is invalid on dvbt models)
  • fix an if/else on the atsc/dvb parse preventing tables from being parsed correctly
  • add missing h264 frame detection since mythtv waits for a key frame

Attachments (2)

hdhr-dvbt.patch (2.4 KB) - added by mikeb@… 10 years ago.
siscan.patch (1.1 KB) - added by mikeb@… 10 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by mikeb@…

Attachment: hdhr-dvbt.patch added

Changed 10 years ago by mikeb@…

Attachment: siscan.patch added

comment:1 Changed 10 years ago by mikeb@…

siscan.patch:

HDHRSignalMonitor isn't a member of DVBSignalMonitor; use DTVSignalMonitor to lookup tsid/netid in the siscan code.

comment:2 Changed 10 years ago by danielk

Resolution: wontfix
Status: newclosed

It appears at some but not all of these changes have been made in trunk. We like to fix everything in truck first and wait for reports of regressions before backporting fixes. Also since 0.22 is near we're concentrating our testing effort on it right now.

comment:3 Changed 10 years ago by mikeb@…

While there's no doubt that moving forward to trunk is a better long term strategy, 0.21 still exists as the fallback position and is in need of the above patches; once the above patches have been applied I will be more than happy to move forward and fix the hdhomerun support in trunk/0.22

The siscan.patch has already been applied thanks to the generosity of janne; all that remains is the hdhr-dvbt.patch

comment:4 Changed 10 years ago by danielk

Ticket locked: set

comment:5 Changed 10 years ago by Janne Grunau

(In [21376]) backports H264 support in the HDHomeRun recorder. Refs #6874

patch by: mbm

comment:6 Changed 10 years ago by Janne Grunau

(In [21377]) Fix HDHRRecorder::SetStreamData? for DVB analogous to [20771] in trunk. Refs #6874

comment:7 Changed 10 years ago by Janne Grunau

Milestone: unknown0.22
Resolution: wontfix
Status: closednew
Version: 0.21-fixeshead

comment:8 Changed 10 years ago by Janne Grunau

Owner: changed from danielk to Nigel
Status: newassigned

nigel, I hope you don't mind taking this. Only remaining issue is the modulation in hdhrchannel.cpp. The code is the same in trunk and fixes.

comment:9 Changed 10 years ago by Nigel

(In [21383]) Old HDHR model accepts qam64, DVB one needs t7qam64 or t8qam64. The code currently uses the raw value from the database, so for safety, always force automatic tuning. See #6874

comment:10 Changed 10 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [21384]) Force automatic modulation detection. Backport of [21383]. Closes #6874.

comment:11 Changed 10 years ago by Nigel

(In [21389]) Safer version of [21383]. Refs #6874. Sadly, untested. Necessary because ancient versions of the HDHR firmware don't support auto.

comment:12 Changed 10 years ago by Nigel

(In [21390]) Safer version of [213884]. Refs #6874. Sadly, untested. Necessary because ancient versions of the HDHR firmware don't support auto.

Note: See TracTickets for help on using tickets.