Opened 11 years ago

Closed 11 years ago

#6887 closed defect (duplicate)

QSqlDatabase is closed when still in use

Reported by: Tapio Sami <tapio.sami@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Watched a show, tried to change channel via epg while still on the first channel. Ended up on the main menu. Watch TV again, selected the channel, ended up on the main menu... Did that a couple of times, until FE segfaulted. Log claims that there was some problem with sql, but I can't verify this. After starting FE again, everything works OK again.

Attachments (3)

changingchannelsgdb.txt (102.2 KB) - added by Tapio Sami <tapio.sami@…> 11 years ago.
backtrace
changingchannelsmyth.log (68.7 KB) - added by Tapio Sami <tapio.sami@…> 11 years ago.
frontend log
changingchannelsBE.log (9.3 KB) - added by Tapio Sami <tapio.sami@…> 11 years ago.
backend log

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by Tapio Sami <tapio.sami@…>

Attachment: changingchannelsgdb.txt added

backtrace

Changed 11 years ago by Tapio Sami <tapio.sami@…>

Attachment: changingchannelsmyth.log added

frontend log

Changed 11 years ago by Tapio Sami <tapio.sami@…>

Attachment: changingchannelsBE.log added

backend log

comment:1 Changed 11 years ago by Tapio Sami <tapio.sami@…>

Forgot this:

htpc:/home/mythtv# mythbackend --version Please include all output in bug reports. MythTV Version : 21270M MythTV Branch : trunk Network Protocol : 46 Library API : 0.22.20090813-1 QT Version : 4.5.2 Options compiled in:

linux debug using_alsa using_backend using_dvb using_frontend using_hdpvr using_iptv using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

comment:2 Changed 11 years ago by sphery

Status: newinfoneeded_new
Summary: Tried to change channel, got back to main menu again and again...QSqlDatabase is closed when still in use

It seems this issue stems from:

QSqlDatabasePrivate::removeDatabase: connection 'DBManager3' is still in use, all queries will cease to work.
QSqlDatabasePrivate::addDatabase: duplicate connection name 'DBManager3', old connection removed.

which is shown in changingchannelsmyth.log at 2009-08-22 13:10:26 (during LiveTV playback) just as all further DB queries begin to fail.

Tapio, the fronten log file (changingchannelsmyth.log) seems to be missing some information that would have been included with default verbosity--as if it were created with verbose options, such as -v database, that disabled important and/or general messages. Can you verify the verbose settings and if they do not include important,general and if this is reproducible, please upload a new frontend log with default verbosity (or at least ensure you include important,general before any other log options).

Also, please provide some information on your system layout--which system hosts the MySQL database, the master backend, and the frontend on which you got the error, as well as the distro and version you're using for your frontend. Thanks.

comment:3 Changed 11 years ago by Tapio.Sami@…

I've only seen this few times, with perhaps a couple of weeks since the first time. And yes, I must add important,general to verbose options, if I did not have those. I must check it, can't remember the options. As this happens very rarely, the next backtrace might take quite some time.

I have all on same machine, it's a dedicated myth box. Debian Sid. And both FE and BE are the same version, 21270.

comment:4 Changed 11 years ago by sphery

Refs #6544

comment:5 Changed 11 years ago by stuartm

Resolution: duplicate
Status: infoneeded_newclosed

Duplicate of #6544

Note: See TracTickets for help on using tickets.