Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6957 closed defect (invalid)

xrandr lets cursor reappear

Reported by: gavin@… Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - User Interface Library Version: unknown
Severity: low Keywords:
Cc: Ticket locked: no

Description

In trunk, turning on xrandr caused my mouse cursor to reappear (albiet immobile) after a few resolution/screen changes. I can easily reproduce this.

Attachments (1)

mythtv-0.22-xrefresh.patch (616 bytes) - added by andy 10 years ago.
invoke xrefresh after changing refresh rate

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by JYA

The issue isn't entirely related to mythtv. For example, this didn't used to occur with Ubuntu 8.10, but occurs in 9.04 on my installation.

The same issue changing refresh rate with xrandr while any applications is running full screen would make the mouse cursor reappear.

One work-around is before starting mythtv runs xwit like : /usr/bin/xwit -root -warp x y where x,y are the coordinates of the bottom corner, like /usr/bin/xwit -root -warp 1920 1080

comment:2 Changed 10 years ago by reidjr_at_lineone_net

unfortunately can confirm that 8.10 doesn't have this problem, but 9.04 and the shiny new 9.10 do.

As i have now got xrandr working for me this is another little task to work on :-)

Ref Ticket #7448

comment:3 in reply to:  2 Changed 10 years ago by anonymous

Replying to reidjr_at_lineone_net:

unfortunately can confirm that 8.10 doesn't have this problem, but 9.04 and the shiny new 9.10 do.

As i have now got xrandr working for me this is another little task to work on :-)

Ref Ticket #7448

xrefresh is another way to get rid of the cursor, but beyond my skills to call from myth

comment:4 Changed 10 years ago by stuartm

Severity: mediumlow
Status: newinfoneeded_new

So this is a bug outside myth?

comment:5 Changed 10 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

No response in 2 months and no indications that this is a myth bug rather than an X one.

Changed 10 years ago by andy

Attachment: mythtv-0.22-xrefresh.patch added

invoke xrefresh after changing refresh rate

comment:6 Changed 10 years ago by andy

I can confirm that xrefresh fixes the mouse cursor (running 0.22-fixes on fedora11). Warping the cursor with xwit is better than nothing, but the cursor is still partially visible in the corner.

The patch I attached works for me, but I assume there are better ways of forcing the window to redraw. I tried to find an xlib routine that would do something similar but I couldn't figure it out. I have no idea if the problem is in mythtv, X, or Qt but the quickest fix seems to be in mythtv.

Note: See TracTickets for help on using tickets.