Opened 10 years ago

Closed 9 years ago

Last modified 5 years ago

#7004 closed defect (fixed)

Add new playback entry fails

Reported by: achew22+mythtv@… Owned by: danielk
Priority: trivial Milestone: 0.28
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Dibblah)

When you go into TV Settings | Create a new entry, the entry is added but not displayed. If you hit next and then finish through the whole screen and then go back in the entry exists.

Subversion 21722.

Change History (7)

comment:1 Changed 10 years ago by Dibblah

Description: modified (diff)
Owner: changed from Isaac Richards to danielk
Status: newassigned

Still an issue in 23739.

The log shows 'addentry rejected' even thought the 'Finish' button was selected. Also, the 'Add New Entry' button only works once per entry to the wizard.

comment:2 Changed 10 years ago by Dibblah

Description: modified (diff)

comment:3 Changed 10 years ago by sphery

The "addentry rejected" message is a logging error and is unrelated to the repaint issue. It's caused by an invalid comparison and can be fixed by using kDialogCodeAccepted instead of QDialog::Accepted in the comparison.

comment:4 Changed 10 years ago by sphery

(In [23757]) Fix log output in the Playback Profile group editor.

Fixes a broken comparison whose only effect is outputting an error message when none occurred. The comparison was broken due to changes in [14908], but didn't cause any problems. Refs #7004.

comment:5 Changed 9 years ago by danielk

Resolution: fixed
Status: assignedclosed

Fixed by [23757].

comment:6 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

In b254bb09bbb77d109e8992a2108ec135bf99144b/mythtv:

Fixes Video Playback Profile Editor.

Two corrected issues:
1- Adding or Editing an existing profile, did nothing visually, but would actually update the database
2- When deleting a profile, the newly selected one wasn’t actually saved as default

Was broken since 2007 by the look of things (feature first introduced in aaf6f2b5b1eee055074a72513ca819d97dd687cb)
Fixes #7004 and others

comment:7 Changed 5 years ago by paulh

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.