Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7010 closed defect (fixed)

./cpsvndir causes errors with checkinstall for themes

Reported by: ryan.goat@… Owned by: gigem
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: high Keywords: checkinstall cpsvndir
Cc: Ticket locked: no

Description

I tried upgrading to the latest SVN today. But I'm getting errors when I execute "sudo checkinstall" to build a .deb file. I'm running on ubuntu 9.04 and I've tried running "make distclean" and recompiling but it doesn't help.

These errors cause mythfrontend to fail. Luckily mythbackend is still working.

MythTV Version : 21727M MythTV Branch : trunk Network Protocol : 48 Library API : 0.22.20090905-1 QT Version : 4.5.0 Options compiled in:

linux release using_oss using_alsa using_backend using_directfb using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Here are the errors I saw in the output from checkinstall

make[2]: Leaving directory `/home/ryan/mythtv_svn/trunk/mythtv/programs/mythtranscode'
make[1]: Leaving directory `/home/ryan/mythtv_svn/trunk/mythtv/programs'
cd themes/ && make -f Makefile install
make[1]: Entering directory `/home/ryan/mythtv_svn/trunk/mythtv/themes'
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/blue /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/defaultosd /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/blueosd /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/default /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/default-wide /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/G.A.N.T /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/classic /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/DVR /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/Terra /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/defaultmenu /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/mediacentermenu /usr/share/mythtv/themes/
./cpsvndir: 28: Bad substitution
make[1]: [install_themes] Error 2 (ignored)
install -m 644 -p /home/ryan/mythtv_svn/trunk/mythtv/themes/FreeSans.ttf /usr/share/mythtv/
install -m 644 -p /home/ryan/mythtv_svn/trunk/mythtv/themes/FreeSansBold.ttf /usr/share/mythtv/

Attachments (2)

cpsvndir_mythtv.patch (832 bytes) - added by mythtv@… 10 years ago.
Could someone with 'dash' please try the attached patch?
cpsvndir2.patch (1.5 KB) - added by mythtv@… 10 years ago.
Latest version against HEAD (resolves problem of creating directory named with 'del' character)

Download all attachments as: .zip

Change History (10)

comment:1 in reply to:  description ; Changed 10 years ago by gigem

Owner: changed from Isaac Richards to gigem
Status: newassigned

Replying to ryan.goat@gmail.com:

sh ./cpsvndir /home/ryan/mythtv_svn/trunk/mythtv/themes/blue /usr/share/mythtv/themes/ ./cpsvndir: 28: Bad substitution

What /bin/sh are you using?

comment:2 in reply to:  1 Changed 10 years ago by anonymous

Replying to gigem:

What /bin/sh are you using?

looks like "dash"

comment:3 Changed 10 years ago by sphery

There are tons of bashisms in the current script. In case you haven't noticed the post, I mentioned them on the list, figuring I had more control over the formatting of plain text than wiki text and because I didn't want discussion of how to fix the parts I didn't know how to fix in the bug database. http://mythtv.org/pipermail/mythtv-dev/2009-September/065998.html

comment:4 Changed 10 years ago by anonymous

This ticket is a duplicate of #7006.

Changed 10 years ago by mythtv@…

Attachment: cpsvndir_mythtv.patch added

Could someone with 'dash' please try the attached patch?

comment:5 Changed 10 years ago by gigem

Resolution: fixed
Status: assignedclosed

(In [21739]) Hopefully really fixed the recent problems with cpsvndir. Fixes #7010.

comment:6 Changed 10 years ago by anonymous

It does work indeed with "dash" (Ubuntu 9.04 here: ls -l /bin/sh -> dash ). No more errors and everything installs fine. Thanks for the patch.

Changed 10 years ago by mythtv@…

Attachment: cpsvndir2.patch added

Latest version against HEAD (resolves problem of creating directory named with 'del' character)

comment:7 Changed 10 years ago by gigem

(In [21764]) My last cpsvndir change, honest! If this breaks anything, I give up. Refs #7010.

comment:8 Changed 10 years ago by sphery

(In [21782]) Dereference symlinks for the chown in cpsvndir to ensure link ownership is set properly. Refs #7010.

Note: See TracTickets for help on using tickets.