Opened 10 years ago

Closed 9 years ago

#7023 closed enhancement (fixed)

Modification to change-channel-lirc.pl for Motorola 0 (zero) problem

Reported by: matthew dot shannon at comcast dot net Owned by: Jarod Wilson
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: low Keywords:
Cc: Ticket locked: no

Description

Some IR transmitters have difficulty with the Mototola 0 (zero) ideal IR code (0x0000). This modification to the existing change-channel-lirc.pl script allows for the ideal codes for everything except the troublesome Motorola 0 button.

Attachments (2)

change-channel-lirc_2009083101.pl (1.3 KB) - added by matthew dot shannon at comcast dot net 10 years ago.
modified 'change-channel-lirc.pl' script for Motorola 0 (zero)
lircd.conf (3.1 KB) - added by matthew dot shannon at comcast dot net 10 years ago.
associated lircd.conf with RAW Motorola 0 (zero) IR code

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by matthew dot shannon at comcast dot net

modified 'change-channel-lirc.pl' script for Motorola 0 (zero)

Changed 10 years ago by matthew dot shannon at comcast dot net

Attachment: lircd.conf added

associated lircd.conf with RAW Motorola 0 (zero) IR code

comment:1 Changed 10 years ago by Jarod Wilson

Resolution: worksforme
Status: newclosed

Doing It Wrong(tm). Just add 'min_repeat 2' to your lircd.conf in the non-raw section, and 0 works just fine. Known issue, addressed on the lirc list on more than one occasion now.

comment:2 Changed 10 years ago by anonymous

Thanks for the comment jarod. Unfortunately, I have read the same suggestions, and the 'min_repeat 2' didn't address the problem for me, and others if I have read the comment boards correctly. In fact - the zero still didn't work, and I received repeats of the other IR codes.

In the end, I offered this as a help... My problem is resolved, and the code has been provided to the community.

Best of Luck! Matt

comment:3 in reply to:  2 Changed 10 years ago by Jarod Wilson

Resolution: worksforme
Status: closednew

Replying to anonymous:

Thanks for the comment jarod. Unfortunately, I have read the same suggestions, and the 'min_repeat 2' didn't address the problem for me, and others if I have read the comment boards correctly. In fact - the zero still didn't work, and I received repeats of the other IR codes.

Hrm. Perhaps my memory sucks... I'm now vaguely recalling that you (or someone else) may have indeed brought this up on the lirc list and said the min_repeat setting still didn't help...

In the end, I offered this as a help... My problem is resolved, and the code has been provided to the community.

I'll reopen this for now...

comment:4 Changed 10 years ago by Jarod Wilson

Owner: changed from Isaac Richards to Jarod Wilson
Status: newassigned

comment:5 Changed 10 years ago by Jarod Wilson

This is the thread I was thinking of:

http://news.gmane.org/find-root.php?group=gmane.comp.hardware.lirc&article=8362

The last post from Christoph never got a reply, that could be the missing piece in your setup, Matt.

comment:6 Changed 9 years ago by robertm

Resolution: fixed
Status: assignedclosed

Seems resolved (and if not, please feel free to add this to the channel change script category on the wiki).

Note: See TracTickets for help on using tickets.