Opened 14 years ago

Closed 14 years ago

#703 closed defect (worksforme)

Mythmusic hangs

Reported by: Miah Gregory <mace@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

Running from week old SVN (planning to upgrade tonight).

I've had a search of the various mailing lists and asked on IRC, but no-one's seen this problem before, so I'd like some help in debugging it. Basically the problem is that when you switch tracks in mythmusic, either manually whilst one is playing, or automatically as each track ends, there's around a 10 second delay during which the front end is unresponsive, cpu load is fairly minimal, and if a track was playing at the time, around half a second of audio loops constantly for around 10 seconds. After this delay, the next track starts successfully.

I straced the process and believe that mythmusic was hanging whilst closing the filehandle to /dev/dsp - has anyone seen this before? My suspicion is that the audio code isn't closing down /dev/dsp properly, eg. unmapping buffers or whatever, and hence the close() hangs to allow the buffers to all empty or something?

Very occasionally, mythmusic has crashed whilst attempting the track change, but I've been so far unable to reproduce this in a debugger.

Any help to continue debugging would be appreciated (on irc as mace if that's more convenient).

Change History (1)

comment:1 Changed 14 years ago by paulh

Resolution: worksforme
Status: newclosed

Since you seem to be the only person with this problem it is more likely a problem with your system rather than with mythmusic.

I'm going to mark this as worksforme if you can narrow it down to a definate problem with mythmusic reopen this ticket and add more details about what file format you use, what audio output drivers you are using etc. and a backtrace at the point it hangs would help.

Note: See TracTickets for help on using tickets.