Opened 10 years ago

Closed 10 years ago

#7038 closed defect (fixed)

commit: r21807 causes compile errors for some plugins

Reported by: ryan.goat@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: ryan.goat@… Ticket locked: no

Description

I get the following error when compiling mythplugins with --enable-mythgallery. I get a similar error with --enable-mythbrowser. Maybe other plugins have errors also. I have not trying them all.

/usr/include/mythtv/libmythui/mythuibuttonlist.h: In member function ‘virtual bool IconView::Create()’:
/usr/include/mythtv/libmythui/mythuibuttonlist.h:180: error: ‘void MythUIButtonList::SetActive(bool)’ is protected
iconview.cpp:198: error: within this context
make[2]: *** [iconview.o] Error 1



This seems to be caused by commit: r21807

Change History (3)

comment:1 Changed 10 years ago by stuartm

(In [21810]) Fix compilation of mythgallery.Refs #7038

comment:2 Changed 10 years ago by stuartm

(In [21811]) Fix compilation of mythbrowser. I'm not sure what the intent was for the SetActive?() call here so I've just removed it. I also noticed some redundant calls to MythUIButtonList::Update() which I've removed too. Refs #7038

comment:3 Changed 10 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [21812]) Fix compilation of the bookmark manager. Closes #7038

Note: See TracTickets for help on using tickets.