Opened 14 years ago

Closed 14 years ago

#705 closed defect (worksforme)

db update failed, but db version in setting table still incremented

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After updating to SVN 8027 today, mythfrontend failed with a message that application of database update 1109 had failed. In particular it failed adding the 'generic' column to the 'oldrecorded' table because it was a duplicate column. But, 1109 was recorded as the database version in the settings table as DBSchemaVer.

I deleted the two columns added in 1109 and rolled my version back one from 1109 to 1108 and restarted mythfrontend and the update applied fine. Since the update populates program.generic and oldrecorded.generic only contained the default value, I figured it was safe to drop the columns.

I see two problems with this.

1) Why did the DBSchemaVer get updated even though the update failed? This seems like a bug.

2) Why did this db update attempt to apply twice? I haven't had mythfrontend crap out on launch lately, so I doubt I got a partial update.

Change History (1)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: worksforme
Status: newclosed

Can't reproduce, would need logs of a broken run to debug.

Note: See TracTickets for help on using tickets.