Modify

Opened 8 years ago

Closed 8 years ago

#7057 closed defect (fixed)

Daily schedule does not include weekends.

Reported by: joi@… Owned by: kormoc
Priority: trivial Milestone: 0.24
Component: Plugin - MythWeb Version: head
Severity: low Keywords:
Cc: Ticket locked: yes

Description

Adding a custom schedule for a daily recording where there is no programme data results in weekday recordings but no weekend recordings.

Attachments (1)

mythweb-7057-add_info_on_daily_schedule_start_date.patch (1.2 KB) - added by mdean 8 years ago.
Add usage info for Start Date on Manual Schedule page

Download all attachments as: .zip

Change History (17)

comment:1 Changed 8 years ago by stuartm

  • Status changed from new to infoneeded_new

Can we please have some basic information such as which version you are running (--version)? Is this a new problem? Did it work previously? Are you creating the schedules using mythweb or mythfrontend?

Are you selecting '5 weekdays if daily' instead of '7 days per week if daily' when creating the manual schedule?

comment:2 Changed 8 years ago by joi@…

Oops, sorry,

Backend is from the MythTv?-backend 0.21.0+fixes19961 Ubuntu package.

Schedule is created manually via MythWeb:

  1. select Recording Schedules (manual) (http://localhost/mythweb/tv/schedules/manual)
  2. Check "Record this program in this timeslot every day."
  3. Edit channel and time options...
  4. Click create schedule.

comment:3 Changed 8 years ago by joi@…

... there is now 5 weekdays or 7 days option in the mythweb interface for the manual schedule.

comment:4 Changed 8 years ago by anonymous

"now" = "no"

comment:5 Changed 8 years ago by stuartm

  • Milestone changed from unknown to 0.22
  • Status changed from infoneeded_new to new
  • Version changed from unknown to head

Well I've noticed I introduced a similar bug to mythfrontend in the last couple of days, I fix it there first then bounce this to one of the mythweb guys.

comment:6 Changed 8 years ago by stuartm

  • Owner changed from gigem to stuartm
  • Status changed from new to accepted

comment:7 Changed 8 years ago by stuartm

  • Component changed from MythTV - Scheduling to Plugin - MythWeb
  • Owner changed from stuartm to kormoc
  • Status changed from accepted to assigned

Tested as working in trunk using mythfrontend, so it looks like a mythweb bug.

comment:8 Changed 8 years ago by mdean

Please delete the recording rule, then re-create the rule with a starttime on a Saturday or Sunday. See http://www.gossamer-threads.com/lists/mythtv/users/158185#158185

comment:9 Changed 8 years ago by anonymous

"every day" != every day if it begins on a weekday? "every day" == every day if and only if it begins on a weekend...

well, that's not a very nice interface.

comment:10 Changed 8 years ago by kormoc

  • Milestone changed from 0.22 to 0.22.1

comment:11 Changed 8 years ago by stuarta

  • Milestone changed from 0.22.1 to 0.23

We've decided not to do a 0.22 point release

comment:12 Changed 8 years ago by kormoc

  • Resolution set to invalid
  • Status changed from assigned to closed

Closing this as it's a feature request, not a bug, and not a mythweb issue

comment:13 Changed 8 years ago by anonymous

If your doctor tells you to take a pill daily, do you skip saturdays and sundays?

comment:14 Changed 8 years ago by kormoc

  • Ticket locked set

Changed 8 years ago by mdean

Add usage info for Start Date on Manual Schedule page

comment:15 Changed 8 years ago by mdean

  • Milestone changed from 0.23 to 0.24
  • Priority changed from minor to trivial
  • Resolution invalid deleted
  • Severity changed from medium to low
  • Status changed from closed to new

Added a patch, mythweb-7057-add_info_on_daily_schedule_start_date.patch , which adds information about how the Start Date is used for Daily manual schedules. I will not apply this until after the release, as it adds a new translatable string and we've already frozen strings for translators (and the issue is not high priority since the scheduler has been like this for many versions and the page has never explained the usage).

A better solution would be a use of JavaScript? that replaces the Start Date label and associated form element with a radio button group allowing the user to select "5 weekdays" or "7 days per week" iff "Record this program in this timeslot every day." is selected and then generates a Start Date for a weekday or weekend day, respectively, depending on the selected value. The Start Date is important for both single record ("Record only this showing.") and weekslot ("Record this program in this timeslot every week.") manual recording rules, so it must be user-configurable for those rule types. Similar changes could be made to the mythfrontend UI (see [10721]).

Ideally, we'd also change the UI to use an option list for the Start Date for single and weekslot recordings, and perhaps even use option lists for setting hours, minutes, and seconds of the Start Time to prevent invalid data entry.

comment:16 Changed 8 years ago by mdean

  • Resolution set to fixed
  • Status changed from new to closed

(In [24107]) Fixes #7057. Add text to the MythWeb Manual Schedule page to briefly explain how Start Date is used for daily recordings. This is basically the same description used by mythfrontend.

Anyone interested in making it prettier/more user-friendly should see the comments on #7057 for suggested alternatives.

Add Comment

Modify Ticket

Action
as closed The owner will remain kormoc.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.