Opened 10 years ago

Closed 9 years ago

#7076 closed defect (fixed)

FFW/RW goes very fast when recording exits commercial break

Reported by: Tim Jordan <tim@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When watching recorded shows on Virgin1, my wife likes to fast forward through the advert breaks. If she is not quick enough to stop forwarding at the end of the break, the forwarding continues through the program but instead of carrying on at the speed of the current selected ffw speed it ffws at what seems greater than 120x speed. She then rewinds and the program rewinds at the stated speed until it hits the end of the advert break when it then does the same thing and goes at a very quick speed. After a few of these direction changes (3-4) the playback generally hard locks, requiring a pkill mythfrontend. I can put up a recording for someone to look at, but I think it is an interlaced/progressive problem, with the changes occurring at the advert breaks. This problem only seems to exist on recordings from certain channels (Virgin1, five). This is still present in latest trunk (r21883). Video card is an intel GMA on a Dell Studio Hybrid and I am using xvideo renderer with yadif 2x deinterlacer.

Tim

Attachments (2)

mythfrontend.version.log (758 bytes) - added by Greg <raven2k@…> 9 years ago.
version output
mythfrontend.toofast.12m.log (235.6 KB) - added by Greg <raven2k@…> 9 years ago.
log output with -v playback when fast forwarding go super fast (just after 12 min in)

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by gigem

Resolution: duplicate
Status: newclosed

Please try current trunk. This might be the same problem fixed in [21890]. If it isn't fixed, reopen this ticket.

comment:2 Changed 10 years ago by tim Jordan <tim@…>

Sadly this is still present in 21901.

comment:3 Changed 10 years ago by tim Jordan <tim@…>

Will not let me reopen the ticket Warning: No permission to change ticket fields.

comment:4 Changed 10 years ago by paulh

Resolution: duplicate
Status: closednew
Version: unknownhead

comment:5 Changed 10 years ago by Tim Jordan <tim@…>

I have a sample recording that I can make available, and I can add some logs if required.

comment:6 in reply to:  5 Changed 10 years ago by gigem

Replying to Tim Jordan <tim@wheresrover.co.uk>:

I have a sample recording that I can make available, and I can add some logs if required.

I don't know how useful the logs will be, but you can attach them to this ticket. Please post where I can find the sample recording. If can't or would rather not make it public, send me an email to david at istwok dot net.

comment:7 Changed 10 years ago by Tim Jordan <tim@…>

OK so change 22121 has improved this situation a bit. Basically if I ffw past the lead in then when the program starts the fastforward goes very fast, however for subsequent advert breaks the ffw works normally. So thinking out loud. The breaks are progressive and the program is interlaced and when we ffw we increase the frame (assume this is the right term) rate by the ffw speed, however we are not dividing this by 2 when we hit the interlaced part and therefore 3x becomes 6x or something to this effect.

comment:8 Changed 9 years ago by robertm

Status: newinfoneeded_new

Hi Tim,

Can you please perform a test with current .23-fixes or trunk? Since there were never logs attached to this ticket I can't be sure, but my hunch is if the problem is what I think it was, it shouldn't be possible to trigger in .23-fixes.

comment:9 Changed 9 years ago by robertm

Component: MythTV - GeneralMythTV - Video Playback

comment:10 Changed 9 years ago by robertm

Resolution: fixed
Status: infoneeded_newclosed

Closing as no response and *I believe* should be fixed in .23-rc3 or later. If you upgrade to curent .23-fixes and find this is still an issue, please feel free to re-open this.

comment:11 Changed 9 years ago by Greg <raven2k@…>

Resolution: fixed
Status: closednew

I believe I am hitting this problem and I am using .23-fixes (revision 24486). I will attach version output and a log where I start mythfrontend, select a recording, skip 12 minutes in (that is where I first see the problem when fast forwarding) and fast forward at 10x. Very shortly thereafter, the fast forward goes extremely fast and I let it go to the end of the recording (30 minute show).

In my experience, this very fast forward only occurs on standard def shows. I have not had the problem with anything in 720 or 1080 p/i. It also only appears to happen during commercial breaks. Fast forwarding through any other parts of the show have not caused this problem.

In this instance, I am using a machine with an nVidia 8800GTX (no vdpau), but the same thing happens on another machine using a 9400GT with vdpau.

Changed 9 years ago by Greg <raven2k@…>

Attachment: mythfrontend.version.log added

version output

Changed 9 years ago by Greg <raven2k@…>

log output with -v playback when fast forwarding go super fast (just after 12 min in)

comment:12 Changed 9 years ago by robertm

Resolution: fixed
Status: newclosed

Partially out of ticket cleanup, and partially out of infoneeded, I am closing this for now because the video output classes have been totally rewritten in trunk/.24. If this persists in .24 or very current trunk, reopen and we will assign.

Note: See TracTickets for help on using tickets.