Opened 10 years ago

Closed 10 years ago

#7079 closed defect (invalid)

Jamu crashes in some instances

Reported by: JYA Owned by: robertm
Priority: minor Milestone: 0.22
Component: Contributed Scripts & Apps Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

When running jamu using the default example.conf file modified as listed in the wiki.

When running jamu in batch mode, it crashes after a little while with error like:

Now processing video file (Tomb.Raider.Ascension)(20)(8)

Entry exists in MythDB but category is 0 and year is 1895 (default values). Updating (Tomb.Raider.Ascension.2008).

! Warning: Series (Tomb Raider Ascension) not found tvdb Series not found(Tomb.Raider.Ascension.2008) meta data dictionary cannot be returned Traceback (most recent call last):

File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 5421, in <module>

main()

File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 5406, in main

process.processMythTvMetaData()

File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 4689, in processMythTvMetaData

tmp_dict = self._getTvdbMetadata(cfile, copy)

File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 3561, in _getTvdbMetadata

return self._getSecondarySourceMetadata(cfile, available_metadata)

File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 3329, in _getSecondarySourceMetadata

tmp_files = (callCommandLine(source % cfile)).decode("utf8")

KeyError?: 'imdb' mythtv@htpc:~$

Change History (5)

comment:1 Changed 10 years ago by JYA

Component: MythTV - GeneralContributed Scripts & Apps

comment:2 Changed 10 years ago by robertm

Status: newinfoneeded_new

Can you please post the exact filename that it is failing on? Not able to reproduce w/ Jamu in current trunk with filenames of:

Tomb.Raider.Ascension.2008.mkv or Tomb.Raider.Ascension.(2008).mkv

Both work fine here and neither I nor the script author are able to trigger a similar failure. Also please post any changes you have made to Jamu.py or the config file as making a mistake there could have some bearing.

comment:3 Changed 10 years ago by JYA

Status: infoneeded_newnew

The original file name was: Tomb.Raider.Ascension.2008.DVDRip.DivX.WBZ.avi

comment:5 Changed 10 years ago by r.d.vaughan@…

jyavenard, two things are going on here. One your movie file naming convention is being recognized as a TV series. The second is that in your Jamu configuration file section [tv-secondary-sources] "metadata:" you have included the parameter "%%(imdb)s" which is not valid for TV series.

To the best of my knowledge there are no TV metadata secondary source scripts. If you created your own script then a TV secondary source will accept a %%(name)s, %%(subtitle)s, %%(season)d, %%(episode)d, %%(filename)s, %%(fullfilename)s. For the meaning of those variables see the documentation in the jamu configuration file.

To stop the abort remove the [tv-secondary-sources] "metadata:" entry. Also rename your movie video file.

comment:6 Changed 10 years ago by Rob Smith

Resolution: invalid
Status: newclosed
Ticket locked: set

Removing all mention of copyrighted material and mlocking the ticket. We do not support *anyone* with pirated material, user or developer, as per project policy.

Note: See TracTickets for help on using tickets.