Opened 14 years ago

Closed 14 years ago

#709 closed defect (fixed)

No response after changing inputs

Reported by: tommi@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've been having a problem with channel changing for a few weeks, am not sure exactly which svn version.

When I use the up/down arrows to change channels there is no problem. If I change channel by hitting the channel number it's ok if it's on the same input. If I change the channel from a channel on one input to a channel on a different input, analogue <-> composite the frontend keeps on playing the channel it was originally on and the frontend becomes totally unresponsive.

The only thing I get on the frontend is the following (-v important,general,playback,channel,osd,file,schedule,jobqueue,siparser):

2005-11-21 21:17:19.793 TV: CommitQueuedInput() livetv(1) qchannum(5) qchanid(0)
2005-11-21 21:17:19.901 TV: ChangeChannel(0, '5')

And then it continues to play the original channel:

2005-11-21 21:17:19.931 AFD: positionMap[ 732 ] == 226412094.
2005-11-21 21:17:20.414 AFD: positionMap[ 733 ] == 226709582.
2005-11-21 21:17:20.891 AFD: positionMap[ 734 ] == 227019358.
2005-11-21 21:17:21.371 AFD: positionMap[ 735 ] == 227349614.

Change History (6)

comment:1 Changed 14 years ago by anonymous

I tried doing the same thing on Linux which was also unsuccesfull but in a different way.

MythTV is already using all available inputs for the channel you selected...

output from stdout

2005-11-28 00:26:08.488 TV: CommitQueuedInput() livetv(1) qchannum() qchanid(0)
2005-11-28 00:26:08.516 TV: ChangeChannel(0, '5')

Is there a chance that while looking for a free card/input for the channel it is not clearing the currently used card? I'm just guessing from reading some code...

Found that RemoteEncoder? *RemoteRequestFreeRecorderFromList?(QStringList &qualifiedRecorders) in libs/libmythtv/remoteutil.cpp always returns NULL. It goes past the first if statement but I'm not enough of an expert to figure out what happens next, I'll try to do more digging tomorrow.

But as a workaround, turning off "Always use Browse mode when changing channels in LiveTV" fixes the problem if you only use the up/down arrows to change channels.

comment:2 Changed 14 years ago by tommi@…

The first example was done on MacOS X Tiger, second one on Linux, Fedora Core 4.

comment:3 Changed 14 years ago by Isaac Richards

Resolution: worksforme
Status: newclosed

Can't reproduce. C successfully switches between tuner + svideo 0 inputs for me.

comment:4 Changed 14 years ago by tommi@…

Switching inputs with C might work but assigning a channel to the svideo/composite input and pressing the number for the channel or using browse mode to change to a channel does not work as I have already described above.

I will download a new svn version and test it.

comment:5 Changed 14 years ago by anonymous

Resolution: worksforme
Status: closedreopened

I have confirmed that indeed the C button works, so the problem remains that changing channels by using browse mode or by number will indeed give the message

MythTV is already using all available inputs for the channel you selected

comment:6 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: reopenedclosed

(In [8249]) Make CheckChannelPrefix? check on all inputs on the card. Fixes #709.

Note: See TracTickets for help on using tickets.