Opened 10 years ago

Closed 10 years ago

#7097 closed defect (fixed)

mythfrontend crashed with SIGSEGV in QVariant::QVariant()

Reported by: mrand@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: Plugin - MythWeather Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Package: mythtv-frontend 0.22.0~trunk21785-0ubuntu2 ProcVersionSignature?: Ubuntu 2.6.31-10.34-generic SegvAnalysis?:

Segfault happened at: 0x7f27fea116f6 <_ZN8QVariantC1ERKS_+22>: mov (%rsi),%rcx PC (0x7f27fea116f6) ok source "(%rsi)" (0x00000038) not located in a known VMA region (needed readable region)! destination "%rcx" ok

SegvReason?: reading NULL VMA Signal: 11 SourcePackage?: mythtv Summary of Stacktrace:

QVariant::QVariant(QVariant const&) () MythUIButtonListItem::GetData?() () SourceSetup::saveData() () SourceSetup::qt_metacall(QMetaObject::Call, int, void) () from /usr/lib/mythtv/plugins/libmythweather.so QMetaObject::activate(QObject*, int, int, void) ()

A bit more info can be found here: https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/432894

Attachments (1)

Stacktrace.txt (20.9 KB) - added by mrand@… 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by mrand@…

Attachment: Stacktrace.txt added

comment:1 Changed 10 years ago by anonymous

sorry... lost the code formatting there. It was intended to be:

SegvAnalysis:
 Segfault happened at: 0x7f27fea116f6 <_ZN8QVariantC1ERKS_+22>: mov (%rsi),%rcx
 PC (0x7f27fea116f6) ok
 source "(%rsi)" (0x00000038) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: mythtv
Summary of Stacktrace:
 QVariant::QVariant(QVariant const&) ()
 MythUIButtonListItem::GetData() ()
 SourceSetup::saveData() ()
 SourceSetup::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/mythtv/plugins/libmythweather.so
 QMetaObject::activate(QObject*, int, int, void**) ()
Title: mythfrontend.real crashed with SIGSEGV in QVariant::QVariant()
Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin mythtv plugdev sambashare

More complete stacktrace is attached.

comment:2 Changed 10 years ago by stuartm

Component: MythTV - GeneralPlugin - MythWeather
Milestone: unknown0.22

comment:3 Changed 10 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [21949]) Fix null pointer segfault in mythweather. Fixes #7097

Note: See TracTickets for help on using tickets.