Opened 10 years ago

Closed 10 years ago

#7109 closed defect (fixed)

[PATCH i18n] Norwegian translation

Reported by: rune.evjen@… Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: Translations Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Updated Norwegian translation.

Attachments (2)

translation.diff (191.9 KB) - added by rune.evjen@… 10 years ago.
translation_v2.tgz (50.2 KB) - added by rune.evjen@… 10 years ago.
Updated and final version of the Norwegian translation

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by rune.evjen@…

Attachment: translation.diff added

comment:1 Changed 10 years ago by anonymous

After reviewing the translation, I found some errors. Please ignore the updated translation for now.

I am also experiensing som problems with all strings containing %n. In Linguist, I get the error message "Translation does not contain the necessary %n place marker."

I also notice that in MythTV the translated string which contains %n is not used.

In the mythfrontend_nb.ts file it seems like the xml code is correct, this is an example of a %n translation that is not working:

<message numerus="yes">

<source>%n hour(s)</source> <translation>

<numerusform>%n time</numerusform> <numerusform>%n timer</numerusform>

</translation>

</message>

How can I fix this ?

Rune

comment:2 Changed 10 years ago by stuartm

    <message numerus="yes">
        <location filename="../libs/libmythtv/progdetails.cpp" line="595"/>
        <location filename="../libs/libmythtv/programinfo.cpp" line="715"/>
        <location filename="../libs/libmythtv/scheduledrecording.cpp" line="345"/>
        <location filename="../programs/mythfrontend/statusbox.cpp" line="985"/>
        <source>%n hour(s)</source>
        <translation>
            <numerusform>%n hour</numerusform>
            <numerusform>%n hours</numerusform>
        </translation>
    </message>

Where are the locations in your version?

comment:3 Changed 10 years ago by anonymous

How do I find the locations ?

I am currently running trunk from yesterday with this version info: mythfrontend version: trunk [21964M]

Also, it seems like this is happending to all %n occurences, not just the %n hour(s) instance.

comment:4 Changed 10 years ago by stuartm

Which version of lupdate are you using?

lupdate -version

Have you tried re-running lupdate translate.pro?

comment:5 in reply to:  4 Changed 10 years ago by anonymous

Replying to stuartm:

Which version of lupdate are you using?

lupdate -version

Have you tried re-running lupdate translate.pro?

I have lupdate version 4.5.0

I reran lupdate (but it reported no updates), did a make distclean and configure and recompiled, and now it seems like it works fine. I will search some more though the menus but it seems that the problem is solved.

I will submit a new diff after some more translation (and some testing to confirm that it works).

Rune

Changed 10 years ago by rune.evjen@…

Attachment: translation_v2.tgz added

Updated and final version of the Norwegian translation

comment:6 Changed 10 years ago by Janne Grunau

Owner: changed from Reynaldo H. Verdejo Pinochet to Janne Grunau
Status: newaccepted

comment:7 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

(In [22195]) update norwegian translations. Fixes #7109

Note: See TracTickets for help on using tickets.