Opened 11 years ago

Closed 11 years ago

#7113 closed defect (fixed)

DVD Menu looped audio plays too fast

Reported by: Marc Randolph <mrand@…> Owned by: skamithi
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Reported by mythbuntu user:

I have at least 2 DVD ISOs that worked fine under Jaunty and myth 0.21 that now have audio messed up at the DVD Menu.

The samples I played are from Robot Chicken Season 1 & 2. At the DVD Menu, there's an audio track that plays that's about one and a half minutes long and then it loops. Under karmic/mythtv trunk, the audio plays fine for 5-10 seconds and then plays really fast for 3-5 seconds and then stops. I can't tell if it plays through the whole track or if something just stops while going fast. The track no longer loops (no audio at menu anymore). From what I can tell, selecting episodes still plays them properly with audio and video being synced. I played an episode for about 2 minutes to make sure.

The machine's hardware is the same between running 0.21 and 0.22/trunk except for a replaced NIC.

Attachments (7)

mythfrontend-dvdmenu.log.bz2 (11.5 KB) - added by mike_hurley_1@… 11 years ago.
mythfrontend -v playback output after sitting at the DVD menu for about 20 seconds
mythfrontend.log.bz2 (21.1 KB) - added by mike_hurley_1@… 11 years ago.
A continuation of the other log file. This one includes picking an episode and playing for a couple minutes. TV was in use, so this was all done via VNC so let me know if you need a rerun.
mythfrontend-anotherdisc.log.bz2 (85.4 KB) - added by mike_hurley_1@… 11 years ago.
Another log playing another DVD's menu and 15 seconds of an episode.
mythfrontend-thirddisc.log.bz2 (112.2 KB) - added by mike_hurley_1@… 11 years ago.
Another disc's log. Same problem. This is a different show, different DVD publisher.
mythfrontend-s1d1.log.bz2 (22.6 KB) - added by mike_hurley_1@… 11 years ago.
playback,extra log of S1D1 up until a couple seconds after the audio cuts out.
mythfrontend-s2d1.log.bz2 (241.5 KB) - added by mike_hurley_1@… 11 years ago.
S2D1 for about 15-20 seconds after the audio started going fast/getting garbled. This one didn't stop and to limit size I didn't wait. Longer looping track?
ticket_7113_potential_fix.diff (1.1 KB) - added by skamithi 11 years ago.
potential fix for the problem. have no time to test it. waiting for feedback.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 11 years ago by robertm

Component: Plugin - MythVideoMythTV - DVD Playback
Owner: changed from Anduin Withers to skamithi

comment:2 Changed 11 years ago by mike_hurley_1@…

I'm the user that entered the defect in mythbuntu. Let me know if you need anything else.

comment:3 Changed 11 years ago by robertm

Status: newinfoneeded_new

Mike,

Frontend logs illustrating the problem with -v playback would likely be informative.

Changed 11 years ago by mike_hurley_1@…

mythfrontend -v playback output after sitting at the DVD menu for about 20 seconds

Changed 11 years ago by mike_hurley_1@…

Attachment: mythfrontend.log.bz2 added

A continuation of the other log file. This one includes picking an episode and playing for a couple minutes. TV was in use, so this was all done via VNC so let me know if you need a rerun.

Changed 11 years ago by mike_hurley_1@…

Another log playing another DVD's menu and 15 seconds of an episode.

comment:4 Changed 11 years ago by anonymous

The logs I attached are from Robot Chicken, Season 1 Disc 1 (first 2 logs) and Season 2 Disc 1 (anotherdisc log). Replaying to get the logs, S1D1 had the behavior as initially described. S2D1 kept playing fast and didn't stop like it had previously. I'm wondering if it's playing fast or just sounds garbled, but I really can't tell.

Changed 11 years ago by mike_hurley_1@…

Another disc's log. Same problem. This is a different show, different DVD publisher.

comment:5 Changed 11 years ago by mike_hurley_1@…

The anotherdisc and thirddisc logs were run without VNC running.

comment:6 Changed 11 years ago by skamithi

i see what the problem is..it occurs when the video is paused but it is not in a dvd still frame and the audio continues. In this case I'm not sure why its exiting from DVD still frame mode but still pausing the video..Guess i may need to tweak the dvd still frame detection some more after all the recent audio/ffmpeg changes. can you send the "-v playback,extra" output from "Season 2 Disc 1" when playing the dvd menu. Note this will produce *a lot* of output. please exit mythtv as soon as the audio fades away.

Changed 11 years ago by mike_hurley_1@…

Attachment: mythfrontend-s1d1.log.bz2 added

playback,extra log of S1D1 up until a couple seconds after the audio cuts out.

Changed 11 years ago by mike_hurley_1@…

Attachment: mythfrontend-s2d1.log.bz2 added

S2D1 for about 15-20 seconds after the audio started going fast/getting garbled. This one didn't stop and to limit size I didn't wait. Longer looping track?

comment:7 Changed 11 years ago by mike_hurley_1@…

While getting these logs I've also noticed this message apparently output to stderr since I redirect stdout.

libdvdread: Encrypted DVD support unavailable.

Why does it think my unencrypted DVD ISO is encrypted? Is this just a general warning?

Also, when I grabbed S2D1's playback,extra log, this also was on stderr.

Error in my_thread_global_end(): 1 threads didn't exit
(I didn't notice this message earlier)

comment:8 Changed 11 years ago by Marc Randolph <mrand@…>

Another log with just -v playback is here:

http://launchpadlibrarian.net/32204389/mf-v.log

This one may or may not be a related problem:

"audio will play fine for a few seconds then get really fast. Eventually the video will go really fast as well. This isn't in the menu though"

If it needs a new ticket and/or also needs -v playback,extra just say the word.

Changed 11 years ago by skamithi

potential fix for the problem. have no time to test it. waiting for feedback.

comment:9 Changed 11 years ago by skamithi

Status: infoneeded_newnew

mike_hurley: pls test the attached patch

comment:10 Changed 11 years ago by skamithi

Status: newassigned

comment:11 Changed 11 years ago by skamithi

Resolution: fixed
Status: assignedclosed

(In [22120]) Closes #7113. internal dvd player: recent dvd code updates in trunk didn't account for dvd still frame with audio. made the necessary changes to resolve this. tested fix on lord of rings (the two towers) special features dvd.

comment:12 Changed 11 years ago by mike_hurley_1@…

I was able to try this fix out last night. The problem mostly seems fixed. Audio doesn't get garbled after a few seconds anymore and keeps playing properly after sitting there a bit.

I'll see if I can get some logs of this, but can you test some of your DVDs/ISOs and try using the menu? I thought I had it pretty repeatable until I tried -v playback,extra and then it always behaved properly.

It seems sometimes the first time I go into any ISO the background looks ok and audio plays ok but the menu is unusable. Actually the whole remote is unusable as I'm unable to go back to the video listing. My irexec events still work so I'm easily able to reboot the machine. After reboot, usually the file that was a problem before will work ok. If the first ISO I go into has no problems, any tried after it never seem to have problems that I remember.

comment:13 Changed 11 years ago by skamithi

bad code fix. user on mythtv-dev reported that this patch is causing dvd playback issues. will consult the user on mythtv-dev list who reported the problem to test new patches that will resolve the audio problem reported in this ticket and not cause any dvd playback issues.

comment:14 Changed 11 years ago by skamithi

Resolution: fixed
Status: closednew

comment:15 Changed 11 years ago by skamithi

Status: newaccepted

comment:16 Changed 11 years ago by skamithi

Resolution: fixed
Status: acceptedclosed

reports on mythtv-dev show that this patch had nothing to do with dvd playback issues. closing the ticket.

Note: See TracTickets for help on using tickets.