Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7146 closed defect (worksforme)

Call to a member function query_col()

Reported by: pavkamlc@… Owned by: Rob Smith
Priority: major Milestone: 0.22
Component: Plugin - MythWeb Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

On Ubuntu Karmic, after install this version of mythweb 0.22.0~trunk22009-0ubuntu0~mythbuntu3 after instalation I've got this message:

Fatal error: Call to a member function query_col() on a non-object in /var/www/mythweb/modules/backend_log/init.php on line 19

Change History (9)

comment:1 Changed 9 years ago by Rob Smith

Status: newinfoneeded_new

Uuh... the rest of the webapp works?

comment:2 Changed 9 years ago by pavkamlc@…

No, application totally don't works. Only display this message:

MythTV

Fatal error: Call to a member function query_col() on a non-object in /usr/share/mythtv/mythweb/modules/backend_log/init.php on line 19

comment:3 Changed 9 years ago by Rob Smith

and going to other modules give you the same message?

comment:4 Changed 9 years ago by pavkamlc

I had to reinstall my system, so I can't reproduce this bug, sorry. Thanx for help.

comment:5 Changed 9 years ago by Rob Smith

Resolution: worksforme
Status: infoneeded_newclosed

comment:6 Changed 9 years ago by g.carabetta@…

I'm having the same problem.

Ubuntu 9.10 and mythweb from 0.22-fixes.

I did as indicated in INSTALL, and:

  • accessing to the folder via web (ie: http://127.0.0.1/) does not access the mythweb.php file;
  • accessing directly at such file, I got:

Warning at /var/www/modules/_shared/tmpl/_errors/db_vars_error.php, line 23: require(modules/_shared/tmpl/tmpl/header.php) [function.require]: failed to open stream: No such file or directory

Fatal error: require() [function.require]: Failed opening required 'modules/_shared/tmpl/tmpl/header.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/modules/_shared/tmpl/_errors/db_vars_error.php on line 23

  • as a workaround, I made a copy of modules/_shared/tmpl/default in modules/_shared/tmpl/tmpl
  • conseguently, I got the error:

Fatal error: Call to a member function query_col() on a non-object in /var/www/modules/backend_log/init.php on line 19

just trying to access the initial (?) page mythweb.php

comment:7 Changed 9 years ago by anonymous

I have the same error as above. The $db variable isnt defined prior to including the backend_log/init.php file

nor is tmpl. I just defined tmpl as "default" in the mythweb.php to get past the first error

comment:8 Changed 9 years ago by anonymous

I had this error, and it was caused by the mysql password being incorrect. I fixed that and now i dont get any php errors (i also dont get anything at all)

There should be a better error message for mysql connection failing

comment:9 Changed 9 years ago by sphery

Refs #8158

Note: See TracTickets for help on using tickets.