Opened 10 years ago

Closed 8 years ago

#7192 closed defect (Fixed)

Creation of custom rules is broken

Reported by: gigem Owned by: stuartm
Priority: critical Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: yes

Description

Creation of custom rules using the MENU key + "Custom Edit" option (as opposed to the "Custom Record" main menu item) is broken in multiple ways.

  1. The custom rule dialog is probably missing a background so the previous screen shows through making navigation very tricky.
  1. After creating a valid SQL clause and then pressing the "Test" button brings a ProgLister?, but it doesn't have a background either so the screen gets even messier.
  1. After creating a valid SQL clause and then pressing the "Record" button, the rule editor doesn't appear.
  1. In the SQL multi-line text entry box, the cursor is not positioned properly for wrapped text. The cursor behaves as if the text is all on one very long line instead of wrapped. FWIW, this happens when creating a custom rule from the main menu path too.

Change History (20)

comment:1 Changed 10 years ago by stuartm

Status: newinfoneeded_new

Which screen are you starting from? It shouldn't have any relevance but I can't reproduce all of these so ... Also need to know which theme?

The first two are almost definitely theme issues, although not present with Terra.

The third I can't reproduce at all, if the rule has both a title and valid SQL then the schedule editor appears. If the SQL is bogus an error dialog (mis-using the menu dialog) appears.

The fourth is a known problem, I haven't written the multiline text editor support yet so it's using a stretched single line edit. The intention was that I'd write this before the release, I've just been dragging my heals.

comment:2 Changed 10 years ago by gigem

Status: infoneeded_newnew

I see issues using Terra, Mythcenter-wide and Mythcenter. It looks like it might also be a focus issue in addition to theme/background issues.

Anyway, for one example, go to Manage Recordings / Schedule Recordings / Search Lists / Channels. Then choose a channel, then a show, press MENU and choose Custom Edit.

comment:3 Changed 10 years ago by stuartm

Status: newaccepted

Ok, seems to be a bug in the Program Lister and no-where else that I've looked yet. The custom editor is being added to the wrong stack, easy fix.

comment:4 Changed 10 years ago by stuartm

(In [22096]) Add the CustomEdit? screen to the correct stack in the ProgLister?. Refs #7192

comment:5 Changed 10 years ago by stuartm

Milestone: 0.22unknown

1 & 2 should be fixed, I can't reproduce 3 and 4 is a known problem.

comment:6 Changed 10 years ago by gigem

I don't see 3 anymore.

comment:7 Changed 9 years ago by wilson.joe@…

If I go into the custom record, and begin adding code by hand, it will eventually crash completely. I shut down numerous times because my scheduled recording rules would appear as gone, and when attempting live TV it would say that the card is busy but not in use. eventually after many reboots they would reappear. I believe is is a lot more than just a theme issue, when the hard drive rev up like its being over worked and then it call comes crashing down..

comment:8 Changed 9 years ago by paulh

Milestone: unknown0.23
Priority: minorblocker

comment:9 Changed 9 years ago by stuartm

Status: acceptedinfoneeded

We need a backtrace.

comment:10 in reply to:  9 Changed 9 years ago by paulh

Replying to stuartm:

We need a backtrace.

Stuart, The main issue remaining is the multi-line edit so we can actually use the custom rule editor. I suspect the issue wilson.joe is having is probably local to him but we'll have a better idea when we can use this screen properly.

comment:11 Changed 9 years ago by stuartm

Paul, still aware of the need to finish the multi-line edit

comment:12 Changed 9 years ago by danielk

Priority: blockercritical

Downgrading this because it was broken in 0.22 and it doesn't appear that anyone is working on this.

comment:13 Changed 9 years ago by robertm

Status: infoneededassigned

comment:14 Changed 9 years ago by Stuart Auchterlonie

Milestone: 0.230.23-fixes

comment:15 Changed 9 years ago by robertm

Milestone: 0.23-fixes0.24

Obviously not getting touched for .23-- Not sure we'll see multi-line textedit for .24, either, but stuartm can change this if we aren't.

comment:16 Changed 9 years ago by stuartm

Severity: mediumhigh
Status: assignedaccepted
Version: headTrunk Head

comment:17 Changed 9 years ago by stuartm

Milestone: 0.24unknown

I'm stuck, the qt method we use for determining the text bounding box and cursor position doesn't work very well and it's not going to work at all for multiline text. I haven't had a better idea yet. QTextEdit remains a possibility but I've not had time to experiment with it and I'd use it only reluctantly, it's important that we don't sacrifice the basics of themability or have a widget which acts independently of mythui for input etc.

It's unlikely I'm going to get this done in the next two weeks but whatever I do come up with will be backported.

comment:18 Changed 8 years ago by Jason Lewis <jason@…>

for what its worth, this problem happens in MythCenter? and Terra.

comment:19 Changed 8 years ago by stuartm

Ticket locked: set

comment:20 Changed 8 years ago by paulh

Milestone: unknown0.25
Resolution: Fixed
Status: acceptedclosed

I'm assuming this one can be closed now we have a working multi-line edit.

Note: See TracTickets for help on using tickets.