Opened 10 years ago

Closed 9 years ago

#7213 closed defect (fixed)

Entering setup causes ASSERT: "hdc" in file image\qnativeimage.cpp, line 106 when using Terra

Reported by: Jonathan Martens <jonathan@…> Owned by: robertm
Priority: minor Milestone: 0.24
Component: Ports - Windows Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythfrontend on windows crashes when trying to enter Setup > Setup when using Terra with the following message:

ASSERT: "hdc" in file image\qnativeimage.cpp, line 106

Attached are the log file and the gdb trace.

Attachments (3)

mythtv-frontend.log (171.0 KB) - added by Jonathan Martens <jonathan@…> 10 years ago.
gdb.txt (153 bytes) - added by Jonathan Martens <jonathan@…> 10 years ago.
7213-w32pkgr-qt46.patch.gz (4.9 KB) - added by Jeff Lu <jll544@…> 9 years ago.
Update win32 packager script to Qt 4.6.3 - gzipped due to spam filter

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Jonathan Martens <jonathan@…>

Attachment: mythtv-frontend.log added

Changed 10 years ago by Jonathan Martens <jonathan@…>

Attachment: gdb.txt added

comment:1 Changed 10 years ago by stuartm

Component: MythTV - GeneralPorts - Windows
Owner: changed from Isaac Richards to Nigel

comment:2 Changed 10 years ago by Jonathan Martens <jonathan@…>

Just checked using Graphite and I can perfectly alter setting in setup, so I think the issue is somewhere in the Terra files as when I retry with Terra I still get the error (just tested on trunk r22237)

comment:3 Changed 10 years ago by stuartm

Milestone: 0.220.22.1

comment:4 Changed 10 years ago by Jeff Lu <jll544@…>

FYI, this assert is generated when Qt attempts to allocate GDI objects >10k, which is the limit enforced by Win XP/Vista.

Upcoming Qt 4.6 resolves this issue. When built with Qt 4.6.0-rc1, mythfrontend shows vastly reduced GDI usage, and the Terra theme works correctly.

comment:5 Changed 10 years ago by Stuart Auchterlonie

Milestone: 0.22.10.24

Once we start using Qt 4.6 on windows this ticket can be closed.

comment:6 Changed 9 years ago by robertm

Status: newassigned

Anyone want to patch the windows build script to use 4.6 so we can get this one closed?

Changed 9 years ago by Jeff Lu <jll544@…>

Attachment: 7213-w32pkgr-qt46.patch.gz added

Update win32 packager script to Qt 4.6.3 - gzipped due to spam filter

comment:7 in reply to:  6 Changed 9 years ago by Jeff Lu <jll544@…>

Replying to robertm:

Anyone want to patch the windows build script to use 4.6 so we can get this one closed?

Attaching what I use...

Patch updates the Windows build script to use Qt 4.6.3 and MinGW-gcc 4.4.0. The gcc update is necessitated by DW2 exception handling dependencies in the pre-compiled Qt 4.6.x binaries.

MinGW-gcc is installed using the Qt-supplied bundle because the MinGW-Installer is outdated/depreciated, and its replacement (mingw-get) is still in early alpha.

Patch also adds imageformat plugin installation (for channel icons), lzma archive support (for MinGW components), and some chdir tweaks (for multi-drive environments).

Note that the patched script assumes a clean machine and makes no attempt to handle upgrading of an old MinGW environment. I.e. /mingw and /msys should be deleted before running the new script.

comment:8 Changed 9 years ago by robertm

Owner: changed from Nigel to robertm

comment:9 Changed 9 years ago by robertm

Resolution: fixed
Status: assignedclosed

(In [25856]) Windows Port: Numerous fixes from Jeff Lu, Jonatan Maartens, and Myself to the Windows build script. Makes the build script fully functional without hunting down broken links as of August 25, 2010. Updates Qt to 4.6.3, SVN to 1.6.12, taglib to 1.6.1, and a few others I'm probably forgetting. Fixes #7213. Fixes #8186.

Note: See TracTickets for help on using tickets.