Opened 10 years ago

Closed 10 years ago

#7214 closed defect (invalid)

mythbackend hangs with pvr-150

Reported by: simons.philippe@… Owned by: danielk
Priority: major Milestone: unknown
Component: MythTV - Recording Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythbackend randomly hangs while watching livetv... usually it s happening very quickly after mythbackend is started or it will works for hours...

Attachments (3)

mythbackend.log-20090930 (3.6 KB) - added by simons.philippe@… 10 years ago.
mythbackend.log
core_mythbackend_1255163899.dump.bt (26.7 KB) - added by simons.philippe@… 10 years ago.
mythbackend backtrace
core_mythbackend_1255175396.dump.bt (26.7 KB) - added by simons.philippe@… 10 years ago.
mythbackend backtrace

Download all attachments as: .zip

Change History (15)

Changed 10 years ago by simons.philippe@…

Attachment: mythbackend.log-20090930 added

mythbackend.log

comment:1 Changed 10 years ago by Janne Grunau

Status: newinfoneeded_new

please attach a backtrace of mythbackend when it hangs.

comment:2 Changed 10 years ago by simons.philippe@…

the backend doesnt create a core file when it dies, so I'm not able to create a backtrace this way... I'm not comfortable with running mythbackend inside gdb... but if it's the way to go... i'd like a small procedure for this (like what to do in gdb to start the backend and what to do when my pvr-150 hang)

comment:4 Changed 10 years ago by simons.philippe@…

couldn't reproduce the bug with gdb

comment:5 Changed 10 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

Reporter unable to produce backtrace, marking invalid.

You might want to try attaching to the backend _after_ the deadlock happens:

gdb mythbackend pid_of_mythbackend_process

Changed 10 years ago by simons.philippe@…

mythbackend backtrace

Changed 10 years ago by simons.philippe@…

mythbackend backtrace

comment:6 Changed 10 years ago by simons.philippe@…

finally got my backtraces

comment:7 Changed 10 years ago by simons.philippe@…

is this ticked dead?

comment:8 Changed 10 years ago by cpinkham

Resolution: invalid
Status: closednew

reopening so someone can look at this since we have a backtrace now.

comment:9 Changed 10 years ago by danielk

(In [22502]) Refs #7214. Fixes segfault present in the backtraces.

comment:10 Changed 10 years ago by danielk

(In [22503]) Refs #7214. Backports segfault fix in [22502].

comment:11 Changed 10 years ago by danielk

Milestone: 0.22unknown
Status: newinfoneeded_new

Those backtraces were not for the same problem. We still need those to pursue the deadlock that was originally reported in this ticket...

comment:12 Changed 10 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

No response to request for backtraces.

Note: See TracTickets for help on using tickets.