Opened 10 years ago

Closed 10 years ago

#7215 closed defect (duplicate)

DVB-T channel scanning not working for multiple users

Reported by: Marc Randolph <mrand@…> Owned by: danielk
Priority: minor Milestone: 0.22
Component: MythTV - Channel Scanner Version: head
Severity: medium Keywords: scan, channelscan, channel, dvb, dvb-t, dvbt
Cc: Ticket locked: no

Description

At least three users have reported channel scanning problems. Log attached, supposedly with --verbose channelscan,siparser,channel,record,extra

At least one of them is running:

MythTV Version : 22101
MythTV Branch : trunk
Network Protocol : 48
Library API : 0.22.20090928-1
QT Version : 4.5.2

Attachments (3)

dmesg.txt (50.7 KB) - added by Marc Randolph <mrand@…> 10 years ago.
Card ID info
mythtv-setup.gz (195.8 KB) - added by Marc Randolph <mrand@…> 10 years ago.
mythtv-setup log
mythtv-setup-2nd.gz (28.2 KB) - added by Marc Randolph <mrand@…> 10 years ago.
mythtv-setup log from second user

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by Marc Randolph <mrand@…>

Attachment: dmesg.txt added

Card ID info

Changed 10 years ago by Marc Randolph <mrand@…>

Attachment: mythtv-setup.gz added

mythtv-setup log

Changed 10 years ago by Marc Randolph <mrand@…>

Attachment: mythtv-setup-2nd.gz added

mythtv-setup log from second user

comment:1 Changed 10 years ago by will@…

I've tried to do some rudimentary debugging and I think that the tuner type isn't being passed in to ParseTuningParams? in dtvmultiplex.cpp I will try reverting changeset 21858 and report back if it made any difference tomorrow.

comment:2 Changed 10 years ago by will@…

Going back to revision 21857 allows me to scan on DVB-T again. I don't know enough C++ to be much more help, but I will see if I can work out what's going on. My initial theory is that in the changeover between "OFDM" and "DVBT" something has got missed.

comment:3 Changed 10 years ago by danielk

Milestone: unknown0.22
Status: newassigned

Does the patch on #7232 help?

comment:4 Changed 10 years ago by mythtv@…

While not the original bug raiser, I can confirm the patch in 7232 fixed the issue for me.

comment:5 Changed 10 years ago by stuartm

Resolution: duplicate
Status: assignedclosed

Duplicate of #7232

Note: See TracTickets for help on using tickets.