Opened 10 years ago

Closed 10 years ago

#7229 closed defect (worksforme)

Parental Pin can be bypassed by hitting escape

Reported by: Marc Randolph <mrand@…> Owned by: Anduin Withers
Priority: minor Milestone: 0.22
Component: Plugin - MythVideo Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Forwarding from downstream. Verified on trunk 22101 (sorry can't update at the moment):

*in Mythbuntu, go to "Utilities / Setup", "Setup", "Media Settings", "Video Settings", "General Settings", page 6/7

Settings:

--> Starting Parental Level: 4 - Highest --> Parental Level 4 PIN: 123456 --> Parental Level 3 PIN: 123456 --> Parental Level 2 PIN: 123456 --> Aggressive Parental Control is "ticked"

Go back to the MAIN MENU

Go to "Media Library", "Watch Videos" When it says "Parental Pin: ", press ESCAPE (or stop on RC) For several seconds there is a black patch where it said "Parental Pin:" but after, it goes directly to the videos.

If you then go back, and then re-enter "Watch Videos", it will again ask for the PIN, but again you can press ESCAPE to proceed regardless.

Change History (1)

comment:1 Changed 10 years ago by robertm

Resolution: worksforme
Status: newclosed

As I read the code, and as I understand it, this is behaving as designed. Because you (or the downstream user) have Level 4 as the starting parental level, an aborted PIN defaults to that level (as the setting defines the maximum "safe" level) If the user wishes to limit their kids to only viewing level 1, they should set the starting value to Level 1. In testing, doing so limits the user to level one videos. Moving up to Level two, the user is prompted for a PIN (to allow a jump straight to level 3, or 4) but an abort sets the parental level to level two, and so on.

If any of this needs further explaining, you know where to find me. :)

Note: See TracTickets for help on using tickets.