Opened 10 years ago

Closed 10 years ago

#7259 closed defect (fixed)

setup crashes when attempting to upload channel icon scan results to mythtv.org

Reported by: Stuart Auchterlonie Owned by: stuartm
Priority: minor Milestone: 0.22
Component: MythTV - Mythtv-setup Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using the channel icon downloader, at the end of the process it asks if i want to upload the data to mythtv.org and i say yes, and setup immediately segfaults.

Logs and gdb backtrace attached.

Of particular note are the following 2 lines.

QMutex::lock: mutex lock failure: QMutex::lock: mutex unlock failure:

Stuart

Attachments (4)

setup-crash-post-channel-icon-scan.log (4.2 KB) - added by Stuart Auchterlonie 10 years ago.
Output from setup with a bit of gdb informational messages
setup-crash-post-channel-icon-scan.gdb.txt (19.3 KB) - added by Stuart Auchterlonie 10 years ago.
backtrace
svn-22398-gdb.log (19.6 KB) - added by Stuart Auchterlonie 10 years ago.
Latest backtrace
gbee-7259.patch (1.3 KB) - added by Stuart Auchterlonie 10 years ago.
stuartm's patch to fix issue

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Stuart Auchterlonie

Output from setup with a bit of gdb informational messages

Changed 10 years ago by Stuart Auchterlonie

backtrace

comment:1 Changed 10 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham
Status: newassigned

comment:2 Changed 10 years ago by cpinkham

Can you please try to reproduce this with current trunk, I fixed some MythUIShape bugs in [22333] and this may be related.

comment:3 Changed 10 years ago by cpinkham

If upgrading does not fix this, try setting an environment variable called DISABLETHREADEDMYTHUIIMAGE to '1' and then running again. If the problem still occurs then I do not believe the issue is related to the MythUIImage threading changes that went in recently since the backtrace does not point towards those.

comment:4 Changed 10 years ago by Stuart Auchterlonie

I've retested this with the latest code, with and without DISABLETHREADEDMYTHUIIMAGE and it still segfaults. I'll attach latest backtrace to see if it helps anyone.

Stuart

Changed 10 years ago by Stuart Auchterlonie

Attachment: svn-22398-gdb.log added

Latest backtrace

Changed 10 years ago by Stuart Auchterlonie

Attachment: gbee-7259.patch added

stuartm's patch to fix issue

comment:5 Changed 10 years ago by Stuart Auchterlonie

Owner: changed from cpinkham to stuartm

I've tested the patch that stuartm quickly wrote last night and it does the trick.

Stuart

comment:6 Changed 10 years ago by stuartm

Resolution: fixed
Status: assignedclosed

(In [22418]) Prevent a segfault caused by deleting the icon import screen out from under the submission confirmation dialog. Fixes #7259

Note: See TracTickets for help on using tickets.