Opened 10 years ago

Closed 10 years ago

#7269 closed patch (duplicate)

Add Aspect Ratio and Fill Mode to Playback Groups

Reported by: doug@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi All,

Attached is a patch to add Aspect Ratio and Fill Mode options to playback groups. It includes an update to the db for the two new columns, Combo Boxes for the Playback Groups screen, and calls to toggle the aspect ratio and fill mode when the player starts up.

I hope this helps! Thanks! Doug

Attachments (3)

playgroup.diff (5.3 KB) - added by doug@… 10 years ago.
playgroup2a.diff (4.3 KB) - added by doug@… 10 years ago.
playgroup2b.diff (692 bytes) - added by doug@… 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by doug@…

Attachment: playgroup.diff added

comment:1 Changed 10 years ago by Janne Grunau

Milestone: unknown0.23
Owner: changed from Isaac Richards to Janne Grunau
Status: newaccepted

comment:2 Changed 10 years ago by doug@…

I'm splitting the db changes from the code changes per suggestions from IRC (sphery). Please see the attached patches: playgroup2a.diff (code) and playgroup2b.diff (db). For reference the DB changes are:

  1. Adding two columns to the playgroup table

"ALTER TABLE playgroup ADD COLUMN aspectoverridemode INT NOT NULL DEFAULT 0;"

"ALTER TABLE playgroup ADD COLUMN adjustfillmode INT NOT NULL DEFAULT 0;"

  1. Updating existing playgroups to default these values to 0

UPDATE playgroup SET aspectoverridemode = 0, adjustfillmode = 0;

Thanks!
D

Changed 10 years ago by doug@…

Attachment: playgroup2a.diff added

Changed 10 years ago by doug@…

Attachment: playgroup2b.diff added

comment:3 Changed 10 years ago by paulh

Milestone: 0.230.24

comment:4 Changed 10 years ago by Janne Grunau

Milestone: 0.24
Resolution: duplicate
Status: acceptedclosed

duplicate of the much more general #8088

Note: See TracTickets for help on using tickets.