Opened 14 years ago

Closed 14 years ago

#727 closed defect (invalid)

mythmusic compile error in aacdecoder.cpp

Reported by: mythtv@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

make[2]: Entering directory `/root/mythplugins/mythmusic/mythmusic'
g++ -c -pipe -march=pentiumpro -mmmx -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -I/usr/include/SDL -D_REENTRANT -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"/usr/local\" -DMMX -Di386 -DUSING_DBOX2 -DHAVE_DVDNAV -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I. -I/usr/local/include -I/usr/kde/3.3/include -I/usr/local/include -I/usr/include -I/usr/include -I/usr/include/cdda -I/usr/qt/3/include -I/usr/include -o aacdecoder.o aacdecoder.cpp
aacdecoder.cpp: In member function `bool aacDecoder::initializeMP4()':
aacdecoder.cpp:298: error: invalid conversion from `long unsigned int*' to `
   uint32_t*'

myth mythmusic # gcc -v
Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/specs
Configured with: /var/tmp/portage/gcc-3.3.5.20050130-r1/work/gcc-3.3.5/configure --enable-version-specific-runtime-libs --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/3.3.5-20050130 --includedir=/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/3.3.5-20050130 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/3.3.5-20050130/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/3.3.5-20050130/info --with-gxx-include-dir=/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/include/g++-v3 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --disable-libunwind-exceptions --disable-multilib --disable-libgcj --enable-languages=c,c++,f77 --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 3.3.5-20050130 (Gentoo 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1)

Changing sample_rate to a uint32_t fixed the compile error, but I have no AAC recordings to test functionality on.

Attachments (3)

mythmusic-compile.patch (426 bytes) - added by mythtv@… 14 years ago.
change sample_rate to uint32_t
mythtv-broken_aac.diff (567 bytes) - added by giuly@… 14 years ago.
Cast to (uint32_t*)
mythtv-broken_aac-platform_detection.diff (459 bytes) - added by giuly@… 14 years ago.
Uses uint32_t for x86_64, unsigned long for others

Download all attachments as: .zip

Change History (7)

Changed 14 years ago by mythtv@…

Attachment: mythmusic-compile.patch added

change sample_rate to uint32_t

comment:2 Changed 14 years ago by paulh

Resolution: invalid
Status: newclosed

It compiles fine with the standard unpatched ffaad2 files. The problem is caused by using a patched version that has been changed to make it compatible with 64bit machines.

I think your patch will allow mythmusic to compile with the patched faad2 but will break it for everyone using the standard faad2.

FAAD2: http://www.audiocoding.com/modules/mydownloads/

Changed 14 years ago by giuly@…

Attachment: mythtv-broken_aac.diff added

Cast to (uint32_t*)

comment:3 Changed 14 years ago by anonymous

Resolution: invalid
Status: closedreopened

comment:4 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

That's functionally identical to the patch that was rejected before.

Changed 14 years ago by giuly@…

Uses uint32_t for x86_64, unsigned long for others

Note: See TracTickets for help on using tickets.