Opened 10 years ago

Closed 10 years ago

#7273 closed defect (worksforme)

ttvdb.py crashed with SyntaxError in XML() when downloading metadata

Reported by: Marc Randolph <mrand@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: head
Severity: medium Keywords: ttvdb tvdb_api.py
Cc: Ticket locked: no

Description

InterpreterPath: /usr/bin/python2.6
Package: mythvideo 0.22.0~trunk22101-0ubuntu1
ProcCmdline: python /usr/share/mythtv/mythvideo/scripts/ttvdb.py -D 73800 6 2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
PythonArgs: ['/usr/share/mythtv/mythvideo/scripts/ttvdb.py', '-D', '73800', '6', '2']

Traceback:

Traceback (most recent call last):
  File "/usr/share/mythtv/mythvideo/scripts/ttvdb.py", line 1243, in <module>
    main()
  File "/usr/share/mythtv/mythvideo/scripts/ttvdb.py", line 1069, in main
    seriesfound=searchseries(t, opts, series_season_ep)
  File "/usr/share/mythtv/mythvideo/scripts/ttvdb.py", line 499, in searchseries
    seriesfound=search_for_series(t, series_name)[ int(series_season_ep[1]) ][ int(series_season_ep[2]) ]
  File "/usr/share/mythtv/mythvideo/scripts/ttvdb.py", line 482, in search_for_series
    return tvdb.series_by_sid(sid_or_name)
  File "/usr/share/mythtv/mythvideo/scripts/ttvdb.py", line 473, in _series_by_sid
    self._getShowData(sid)
  File "/usr/share/mythtv/mythvideo/scripts/ttvdb/tvdb_api.py", line 643, in _getShowData
    epsEt = self._getetsrc( self.config['url_epInfo'] % (sid) )
  File "/usr/share/mythtv/mythvideo/scripts/ttvdb/tvdb_api.py", line 427, in _getetsrc
    et = ElementTree.fromstring(src)
  File "<string>", line 86, in XML
SyntaxError: no element found: line 1, column 0

Slightly more info can be found here: https://bugs.launchpad.net/ubuntu/+source/mythplugins/+bug/444055

Change History (1)

comment:1 Changed 10 years ago by robertm

Resolution: worksforme
Status: newclosed

I am unable to reproduce, and both an in-context and command line Query for this item (Desperate Housewives Season 6 Episode 2) work properly. A retry for this user should "just work". It is possible the user has a corrupted tvdb API cache, which can be fixed by doing:

rm -rf /tmp/tvdb_api_*

For reference, a test of this query:

./usr/share/mythtv/mythvideo/scripts/ttvdb.py -D 73800 6 2

Title:Desperate Housewives Season:6 Episode:2 Subtitle:Being Alive Year:2009 ReleaseDate:2009-10-04 Director:David Grossman Plot:Mrs. McCluskey? falls for a steak salesman called Roy Handler. Julie is found unconscious in the park bushes, which questions Mrs. McCluskey?'s decision to tell the police that she saw Angie Bolen's 19-year-old son, Danny, fighting with Julie. UserRating:7.0 Writers:Matt Berry Episode Image:http://www.thetvdb.com/banners/episodes/73800/1124371.jpg Language:en Combined_Episodenumber:2 Epimgflag:2 Id:1124371 Seasonid:83421 Lastupdated:1254738130 Combined_Season:6 Seriesid:73800 Cast:Teri Hatcher, Marcia Cross, Eva Longoria, Felicity Huffman, Dana Delany, Nicollette Sheridan, Lyndsy Fonseca, Josh Henderson, Dougray Scott, Alfre Woodard, Joy Lauren, Shawn Pyfrom, Brenda Strong, Kyle MacLachlan?, Doug Savant, Cody Kasch, James Denton, Ricardo Antonio Chavira, Jesse Metcalfe, Andrea Bowen, Mark Moses, Steven Culp, Neal McDonough? Genres:Drama Runtime:60

Note: See TracTickets for help on using tickets.