Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#7274 closed Bug Report - General (fixed)

Mytharchive shows random file sizes for imported videos

Reported by: Marc Randolph <mrand@…> Owned by: Paul Harrison <pharrison@…>
Priority: minor Milestone: 0.27
Component: Plugin - MythArchive Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Forwarding upstream:

Select a file to archive, and the select archive items screen shows the file as 730750TB. The real size is 96MB. Later, the same file reported 16GB. Tried with various other files and see same behavior across file types (even avi and wmv). All are misreported.

Running 22304. Behavior is not seen on myth recordings.

Change History (13)

comment:1 in reply to:  description Changed 10 years ago by gigem

Replying to Marc Randolph <mrand@pobox.com>:

Running 22304. Behavior is not seen on myth recordings.

You beat me to filing this. Actually it does occur on .nuv Myth recordings, which is where I see the problem.

comment:2 Changed 10 years ago by frail.knight@…

I'm seeing this as well. I am running Mythdora 10.21 upgraded to MythTV 0.22.

comment:3 Changed 9 years ago by robertm

Status: newassigned

comment:4 Changed 9 years ago by anp@…

I've have this problem too. TWhen I , from mytharchive, is creation a VIDEO DVD and get to the "select archive items" screen the size of the selected video is rubbish. The encoder profile is deafult SP and the size can be 12032 TB for a 2 minuets MKV file. If I change the encoding profile to NONE the size is 0 KB. Returning back to SP the size is 0 KB.

I can continue and create the DVD. I use the MYTHCENTER theme and have a fine DVD with chapter menus and pictures.

The mythfrontend version is: [0.24-20110303.1mdv2010.2]

If I run mythfrontend with all debug info, among others I get these lines when creating a DVD with the VIDEO aeblehoest.mkv:

2011-04-07 20:54:21.849 MSqlQuery::exec(DBManager1) SELECT intid, title, plot, length, filename, coverfile, category, showlevel, subtitle, season, episode FROM videometadata ORDER BY title,season,episode <<<< Returns 162 row(s)

2011-04-07 20:54:21.850 MSqlQuery::next(DBManager1) Result: "intid = 353, title = aeblehoest, plot = Mor og Frederikke samler æbler i haven., length = 2, filename = aeblehoest.mkv, coverfile = /video/mythtv/video/pictures/aeblehoest.jpg, category = 0, showlevel = 1, subtitle = , season = 0, episode = 0"

2011-04-07 20:54:23.973 MythUIHelper: LoadCacheImage?(/video/mythtv/video/pictures/aeblehoest.jpg,-video-mythtv-video-pictures-aeblehoest.jpg--140x284.png)

2011-04-07 20:54:23.973 MythUIImage(0xa5d0a2: Load(), spawning thread to load '/video/mythtv/video/pictures/aeblehoest.jpg'

Here is the failure:

2011-04-07 20:54:23.973 VideoSelector?: Cannot find file: aeblehoest.mkv

And now some more debug info:

2011-04-07 20:54:23.973 MythUIImage(0xa5d0a2: LoadImage?(/video/mythtv/video/pictures/aeblehoest.jpg) Object cover_image

2011-04-07 20:54:23.973 MythUIHelper: LoadCacheImage?(/video/mythtv/video/pictures/aeblehoest.jpg,-video-mythtv-video-pictures-aeblehoest.jpg--140x284.png)

2011-04-07 20:54:23.977 MythUIHelper: NOT IN RAM CACHE, Adding, and adding to size :-video-mythtv-video-pictures-aeblehoest.jpg--140x284.png: :159040:

2011-04-07 20:54:23.977 MythUIHelper: MythUIHelper::CacheImage? : Cache Count = :159: size :779876:

2011-04-07 20:54:23.977 MythUIImage(0xa5d0a2: LoadImage? found in cache :-video-mythtv-video-pictures-aeblehoest.jpg--140x284.png: RefCount? = 2

2011-04-07 20:54:36.511 MSqlQuery::exec(DBManager0) DELETE FROM archiveitems;

And because videoselector failed to find info, this happens :

2011-04-07 20:54:36.511 MSqlQuery::exec(DBManager0) INSERT INTO archiveitems (type, title, subtitle, description, startdate, starttime, size, filename, hascutlist, duration, cutduration, videowidth, videoheight, filecodec, videocodec, encoderprofile) VALUES('Video', 'aeblehoest', , 'Mor og Frederikke samler æbler i haven.', , , '0', 'aeblehoest.mkv', 'false', '0', '0', '0', '0', , , 'SP');

I've tried to "google" videoselector but I only got the source file.

comment:5 Changed 8 years ago by t.brackertz@…

It seems that the problem is caused by mytharchivehelper not correctly using the encoding of strings: It only happens if either the title or the filename of a recording or video contains non-ascii-chars.

comment:6 in reply to:  5 Changed 8 years ago by anp@…

Replying to t.brackertz@…:

It seems that the problem is caused by mytharchivehelper not correctly using the encoding of strings: It only happens if either the title or the filename of a recording or video contains non-ascii-chars.

Hi I don't agree. I have the only the problem with videos and not recordings. I have a video where filename and title = '8210' and when creating a dvd the reported filsize is wrong. :-(

comment:7 Changed 8 years ago by stuartm

Type: defectBug Report - General
Version: headMaster Head

comment:8 Changed 8 years ago by paulh

Owner: paulh deleted

comment:9 Changed 6 years ago by Paul Harrison <pharrison@…>

In 9ba735d65a36d6392666c6b468b77c8b8d040b05/mythtv:

MythArchive?: Update the VideoSelector? screen to work with remote files

This also fixes one of the instances where the file sizes would be wrong.
Refs #7274

comment:10 Changed 6 years ago by Paul Harrison <pharrison@…>

In a2cbb1d4d3038df8e242b1a506888d561dfec528/mythtv:

MythArchive?: Update the VideoSelector? screen to work with remote files

This also fixes one of the instances where the file sizes would be wrong.
Refs #7274

(cherry picked from commit 9ba735d65a36d6392666c6b468b77c8b8d040b05)

comment:11 Changed 6 years ago by Paul Harrison <pharrison@…>

Owner: set to Paul Harrison <pharrison@…>
Resolution: fixed
Status: assignedclosed

In 412efbfcada06f2764db161568d5e2787bcfff29/mythtv:

MythArchive?: Add some initial storage group support to Create DVD

This is based on a patch from Lawrence Rust with some changes to make it work
with current Myth.

Also fixes #7274 (sometimes failing to get the proper file size).

comment:12 Changed 6 years ago by Paul Harrison <pharrison@…>

In 8a6d38c6318700a85a71860395c750511e5880c0/mythtv:

MythArchive?: Add some initial storage group support to Create DVD

This is based on a patch from Lawrence Rust with some changes to make it work
with current Myth.

Also fixes #7274 (sometimes failing to get the proper file size).

(cherry picked from commit 412efbfcada06f2764db161568d5e2787bcfff29)

comment:13 Changed 6 years ago by paulh

Milestone: unknown0.27
Note: See TracTickets for help on using tickets.