Opened 10 years ago

Closed 8 years ago

#7309 closed Bug Report - Crash (Works for me)

[CRASH] Mythfrontend Segfault

Reported by: eric.bosch@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Sorry, I did not catch a backtrace, but my wife just tried to manually change the channel to channel 216, which is only available on a tuner group. One tuner, Firewire Device, and the other, SVideo Capture (for those HD channels that are encrypted). The program was being recorded on the SVideo card (second tuner in the group) and instead of popping up message stating that all tuners are busy that can play that channel, mythfrontend segfaulted. Later today, after she goes to sleep, I'll reproduce the error and get a backtrace.

Attachments (3)

gdb.txt (57.0 KB) - added by anonymous 10 years ago.
myth.log (21.0 KB) - added by eric.bosch@… 10 years ago.
Frontend log
mythbackend.log (4.6 KB) - added by eric.bosch@… 10 years ago.
backend log

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by robertm

Milestone: 0.22unknown
Status: newinfoneeded_new

comment:2 Changed 10 years ago by eric.bosch@…

Ok, finally got some time away from work so I could try to replicate this issue. First time, rather than a segfault, mythfrontend got into a deadlock. Attached are frontend log, backend log and gdb backtrace

Changed 10 years ago by anonymous

Attachment: gdb.txt added

Changed 10 years ago by eric.bosch@…

Attachment: myth.log added

Frontend log

Changed 10 years ago by eric.bosch@…

Attachment: mythbackend.log added

backend log

comment:3 Changed 10 years ago by stuartm

Component: MythTV - GeneralMythTV - Video Playback
Owner: changed from Isaac Richards to Janne Grunau
Status: infoneeded_newnew

comment:4 Changed 9 years ago by robertm

Status: newassigned

comment:5 Changed 9 years ago by beirdo

Summary: Mythfrontend Segfault[CRASH] Mythfrontend Segfault

comment:6 Changed 8 years ago by beirdo

Type: defectBug Report - Crash

comment:7 Changed 8 years ago by paulh

Status: assignedinfoneeded

This is a two year old ticket. Can you still reproduce with a current MythTV version?

comment:8 Changed 8 years ago by beirdo

If it stays open, it needs a proper backtrace of the issue. The attached one is stopping at a SIGINT, and is not a crash or even a deadlock.

comment:9 Changed 8 years ago by robertm

Resolution: Works for me
Status: infoneededclosed

No response.

Note: See TracTickets for help on using tickets.