Opened 11 years ago

Closed 11 years ago

#7311 closed defect (invalid)

mythfrontend crashed with SIGSEGV in malloc()

Reported by: Marc Randolph <mrand@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Forwarding upstream:

DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/mythfrontend.real
NonfreeKernelModules: nvidia
Package: mythtv-frontend 0.22.0~trunk22304-0ubuntu1
Uname: Linux 2.6.31-12-generic x86_64

#0  _int_malloc (av=0x7f0248000020, bytes=816) at malloc.c:4404
	nb = 832
	idx = 52
	bin = <value optimized out>
	victim = (mchunkptr) 0x7f024803fc50
	size = 24320
	victim_index = <value optimized out>
	remainder = <value optimized out>
	remainder_size = <value optimized out>
	block = <value optimized out>
	bit = <value optimized out>
	map = <value optimized out>
	fwd = (mchunkptr) 0x7f0248000488
	bck = (mchunkptr) 0x7f00480e5a30
	__PRETTY_FUNCTION__ = "_int_malloc"
#1  0x00007f026a8657ee in *__GI___libc_malloc (bytes=816) at malloc.c:3638
	ar_ptr = (mstate) 0x7f0248000020
	victim = <value optimized out>
	__PRETTY_FUNCTION__ = "__libc_malloc"
#2  0x00007f025ca46c82 in my_malloc () from /usr/lib/libmysqlclient_r.so.16
No symbol table info available.
#3  0x00007f025ca43008 in mysql_stmt_init ()
   from /usr/lib/libmysqlclient_r.so.16
No symbol table info available.
#4  0x00007f025ce0f128 in QMYSQLResult::prepare (this=0x7f0248fecfe0, 
    query=@0x7fff26f6a230) at ../../../sql/drivers/mysql/qsql_mysql.cpp:866
	r = <value optimized out>
	encQuery = {static shared_null = {ref = {_q_value = 27}, alloc = 0, 
    size = 0, data = 0x7f026b73a6f8 "", array = ""}, static shared_empty = {
    ref = {_q_value = 2}, alloc = 0, size = 0, data = 0x7f026b73a718 "", 
    array = ""}, d = 0xa3f138}
#5  0x00007f025ce0eacc in QMYSQLResult::reset (this=0x7f0248fecfe0, 
    query=@0x7fff26f6a230) at ../../../sql/drivers/mysql/qsql_mysql.cpp:660
	encQuery = {static shared_null = {ref = {_q_value = 27}, alloc = 0, 
    size = 0, data = 0x7f026b73a6f8 "", array = ""}, static shared_empty = {
    ref = {_q_value = 2}, alloc = 0, size = 0, data = 0x7f026b73a718 "", 
    array = ""}, d = 0x7f026b73a860}
	numFields = <value optimized out>
#6  0x00007f026caf4196 in QSqlQuery::exec (this=0x7fff26f6a210, 
    query=@0x7fff26f6a230) at kernel/qsqlquery.cpp:375
No locals.
#7  0x00007f026caf57d3 in QSqlDatabase::exec (this=0x1ab78a8, 
    query=@0x7fff26f6a230) at kernel/qsqldatabase.cpp:811
	r = DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjuction with DW_OP_piece.

If this is not actionable, feel free to close.

Change History (2)

comment:1 Changed 11 years ago by danielk

Status: newinfoneeded_new

Is this repeatable? By itself this is no enough info to do anything. But it is probably caused by something writing past the end of a memory allocation. If it is repeatable, valgrind or a similar tool could be used to find out what the cause is.

comment:2 Changed 11 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

30 days without response.

Note: See TracTickets for help on using tickets.