Opened 11 years ago

Closed 10 years ago

#7312 closed defect (worksforme)

making a preview image of a recording that is shorter than the preview offset time fails

Reported by: michael@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

making a preview image of a recording that is shorter than the preview offset time fails. mythtv loops a few times, but instead of going back to earlier frames, it adds 50 frames and tries again (which of course also will fail).

Some (non debug) log snippet: http://pastebin.com/m36add2d5

Change History (2)

comment:1 Changed 11 years ago by michael@…

Adding log snippet here for clarity

2009-10-12 23:00:14.159 Dec: DoFastForward?(): desiredFrame(5149) > last_frame(5100) 2009-10-12 23:00:14.198 Dec: DoFastForward?(): Desired frame is way past the end of the keyframe map!

Seeking to last keyframe instead.

2009-10-12 23:00:14.210 Dec: DoFastForward?(): desiredFrame(5199) > last_frame(5100) 2009-10-12 23:00:14.211 Dec: DoFastForward?(): Desired frame is way past the end of the keyframe map!

Seeking to last keyframe instead.

etc until apparently giving up:

2009-10-12 23:00:14.826 Dec: DoFastForward?(): desiredFrame(6849) > last_frame(5100) 2009-10-12 23:00:14.827 Dec: DoFastForward?(): Desired frame is way past the end of the keyframe map!

Seeking to last keyframe instead.

2009-10-12 23:00:16.829 RingBuf?(/var/lib/mythtv/recordings/1001_20091012225700.mpg): Waited 2.0 seconds for data to become available... 2009-10-12 23:00:18.655 Preview Error: Run() file not local: '/var/lib/mythtv/recordings/1001_20091012225700.mpg'

comment:2 Changed 10 years ago by sphery

Resolution: worksforme
Status: newclosed

Could not reproduce with current 0.23-fixes or trunk.

Note: See TracTickets for help on using tickets.