Opened 10 years ago

Closed 9 years ago

#7335 closed defect (worksforme)

SIGSEGV in frontend when watching H264 recording

Reported by: bhuffman@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I believe this is related to ticket #7207 which I previously posted, but now the videos cause a seg violation. I say "I believe" it's related b/c I don't have any of the old videos (since they're useless other than exhibiting the problem) and since this new video seg faults, I don't see the audio problem.

Attachments (2)

gdb.txt (28.8 KB) - added by bhuffman@… 10 years ago.
myth.log (5.0 KB) - added by bhuffman@… 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by bhuffman@…

Attachment: gdb.txt added

Changed 10 years ago by bhuffman@…

Attachment: myth.log added

comment:1 Changed 10 years ago by bhuffman@…

This is with trunk, revision 22488.

comment:2 Changed 10 years ago by danielk

Status: newinfoneeded_new

Thanks. We will need a short sample of the the video creating this problem. About 15 seconds will do, assuming 7 or so of those seconds are before the segfault.

comment:3 Changed 10 years ago by bhuffman@…

Even a short file is greater than the 511KB that I'm allowed to upload. How can I get the file to you? I have one that's about 8MB.

comment:4 Changed 10 years ago by anonymous

You can produce a 50MB sample using this command:

dd if=sample-file of=small-sample-file bs=1024 count=50000

and then upload here:

http://filebin.ca/

comment:5 Changed 10 years ago by bhuffman@…

comment:6 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:7 Changed 10 years ago by markk

As noted, almost certainly a duplicate of #7207.

Tested with trunk r23324 and video is rendered correctly but playback is broken due to multiple/persistent audio errors (and no audio).

comment:8 Changed 9 years ago by Janne Grunau

Milestone: unknown
Resolution: worksforme
Status: newclosed

video plays fine, audio seems to be in a AAC configuration neither FFmpeg's AAC decoder nor libfaad supports.

Note: See TracTickets for help on using tickets.