Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7342 closed defect (fixed)

LiveTV recordings cannot be deleted from the Watch Recordings

Reported by: otto at kolsi dot fi Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

If LiveTV has been watched, those programs are shown in special 'LiveTV' recgroup in Watch Recordings. When you try to delete one of these recordings, there is a pop-up asking "Are you sure.." but if you answer Yes, nothing happens (program is not deleted).

At the same time, LiveTV recordings can be removed using MythWeb.

Attachments (2)

felogs.txt (57.0 KB) - added by otto at kolsi dot fi 11 years ago.
41_fix_live_delete.dpatch (1000 bytes) - added by mrussotto@… 11 years ago.
patch to fix LiveTV delete

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by stuartm

Resolution: worksforme
Status: newclosed

I can't reproduce this, we'll need more information including logs from the frontend and backend.

Changed 11 years ago by otto at kolsi dot fi

Attachment: felogs.txt added

comment:2 in reply to:  1 Changed 11 years ago by otto at kolsi dot fi

Replying to stuartm:

I can't reproduce this, we'll need more information including logs from the frontend and backend.

I've attached frontend log with -v all (which actually doesn't show much other than MythUI stuff). At the same time backend log with -v all does not show anything.

I'm using the 'Deleted' recgroup instead of removing file immediately, if that is relevant.

Mythfrontend version information:

lease include all output in bug reports.
MythTV Version   : 22495M
MythTV Branch    : trunk
Network Protocol : 50
Library API      : 0.22.20091014-1
QT Version       : 4.5.2
Options compiled in:
 linux profile silent using_alsa using_pulse using_backend using_dvb using_frontend using_hdpvr using_libfftw3 using_lirc using_opengl_video using_opengl_vsync using_qtwebkit using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads

This is happening always and I can reproduce it with local and remote frontend. Log info above was taken with the local frontend in the same machine with backend.

Don't have permissions to re-open the ticket, but IMHO it should be.

comment:3 Changed 11 years ago by cpinkham

Resolution: worksformefixed

(In [22508]) Also search the LiveTV program list in PlaybackBox::findMatchingProg since LiveTV programs are not in the aggregated program list because we do not want them to be displayed under 'All Programs'.

Closes #7342.

comment:4 Changed 11 years ago by cpinkham

(In [22509]) Carry over [22508] from trunk. Search the LiveTV program list in addition to the aggregated list in findMatchingProg since LiveTV programs are not in the aggregated list because we do not want them to display under 'All Programs'.

Refs #7342.

Changed 11 years ago by mrussotto@…

Attachment: 41_fix_live_delete.dpatch added

patch to fix LiveTV delete

Note: See TracTickets for help on using tickets.