Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#7345 closed defect (invalid)

Memory corruption in mythbackend after failed recording of HD-PVR

Reported by: kenneth.emerson@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Either the HD-PVR is not configured properly in myth or the v4l driver has a problem coexisting between the HD-PVR and the HVR-1800 in the same computer (guess). After completing a failed recording attempt on /dev/video0, the backend faults with a malloc error (memory corruption).

MythTV Version : 22481 MythTV Branch : trunk Network Protocol : 50 Library API : 0.22.20091014-1 QT Version : 4.5.0 Options compiled in:

linux release using_oss using_alsa using_backend using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Attachments (2)

mythbackend.log.1 (345.9 KB) - added by kenneth.emerson@… 10 years ago.
messages.txt (75.4 KB) - added by kenneth.emerson@… 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by kenneth.emerson@…

Attachment: mythbackend.log.1 added

Changed 10 years ago by kenneth.emerson@…

Attachment: messages.txt added

comment:1 Changed 10 years ago by robertm

Component: MythTV - GeneralMythTV - Recording
Owner: changed from Isaac Richards to danielk

comment:2 Changed 10 years ago by danielk

Resolution: invalid
Status: newclosed

For any memory corruption please attach a valgrind log.

I'm closing this ticket only because of it's age. If you can reproduce with 0.23, please open a new ticket with the valgrind log in addition to the backend log.

comment:3 Changed 9 years ago by dgatwood <dgatwood@…>

FWIW, I just experienced this crash in 0.23 (25145) a few minutes ago (and apparently last night as well). I've restarted the backend under valgrind. I'll let you know if/when I get another crash.

Note: See TracTickets for help on using tickets.