Opened 10 years ago

Closed 10 years ago

#7363 closed defect (fixed)

mythbrowser: switch keyboard focus impossible

Reported by: Markus Schulz <msc@…> Owned by: paulh
Priority: major Milestone: 0.23
Component: Plugin - MythBrowser Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

it's impossible to switch the keyboard focus. I've changed the key to switch from F1 (see #7359) to "pause"-key. but nothing happens after changing focus, still the keys assigned to myth (r, z, BS, Space, ...) can't be used.

Change History (4)

comment:1 Changed 10 years ago by juho.rutila@…

I can confirm this. I have latest svn version of mythbrowser (22668) and can't type for example my mail address (because it contains .).

comment:2 Changed 10 years ago by Markus Schulz <msc@…>

TOGGLEINPUT is disabled with #if 0 in MythUIWebBrowser::keyPressEvent.

if you enable it (you must remove the VirtualKeyboard? part or it wont compile) it works mostly. There are only some problems to get back to mythtv-context (for showing the menu with "m", ...) but after switching you can pass all keys to the browser input.

comment:3 Changed 10 years ago by paulh

Milestone: unknown0.23

comment:4 Changed 10 years ago by paulh

Resolution: fixed
Status: newclosed

(In [23731]) Re-work the keypress handling in MythUIWebBrowser.

This fixes the TOGGLEINPUT key-binding not working properly so you can now enter text properly on web pages. Also fixes the NEXTLINK, PREVIOUSLINK and FOLLOWLINK key-bindings not working when using a remote with myths lirc support. Fixes #7363, #8139.

Note: See TracTickets for help on using tickets.