Opened 10 years ago

Closed 9 years ago

#7368 closed defect (fixed)

Auto Zoom in TV Playback No Longer Works in 0.22-rc1

Reported by: Bob H <bob.havlin@…> Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: MythTV - Video Playback Version: 0.22rc1
Severity: medium Keywords: auto zoom, letterbox, cropped
Cc: Ticket locked: no

Description

The problem is that the signal on various channels is a mix of HD, letterbox, etc. In release-0.21-fixes I applied the detectLetterboxV7_widescreen_backswitch_fix.patch patch at: http://svn.mythtv.org/trac/ticket/4872

and this worked great to automatically adjust the zoom level when changing through HD and letterbox channels. However, now that I have upgraded to 0.22-rc1 I noticed that the "Auto Zoom" no longer works. In 0.22-rc1, the auto zoom is only set once to whatever channel happens to be set when "Watch TV" is clicked. i.e. if I start out on an HD channel and then change to a SD channel, it appears letterboxed and if I start out on a SD channel (it autozooms as expected) but changing to a HD channel crops all of the edges.

I verified this problem by trying the various options in: ->Utilities/Setup?->Setup->TV Settings->Playback (second screen).

Is it possible to revert to the older 0.21 (V7) patch method?

I have a firewire input, ubuntu-9, compiled mythtv-0.22-rc1.

Thanks, Bob

Change History (4)

comment:1 Changed 10 years ago by Bob H <bob.havlin@…>

Upon further testing, the zoom problem only occurs between channels that are HD and letterbox. SD to HD switching is not a problem presumably because there is not really a zoom applied.

comment:2 Changed 9 years ago by robertm

Component: MythTV - GeneralMythTV - Video Playback
Owner: changed from Isaac Richards to Janne Grunau

comment:3 Changed 9 years ago by Bob H

I have not noticed this problem since upgrading to release-0-22-fixes. Thanks.

comment:4 Changed 9 years ago by stuartm

Milestone: unknown0.22
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.