Opened 11 years ago

Closed 11 years ago

#7370 closed defect (invalid)

mythtvweb & mythmusic -- URLs on playlists not working

Reported by: John L. Poole <jlpoole@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I installed mythtv, mythweb, and mythmusic. I ripped a CD. I can access the music on another machine (Windows XP w/Firefox) and see the 8 tracks from the CD. I altered the the php to allow files to be downloaded.

What happens when I click the playlist, the following playlist is sent to my WinAmp?: #EXTM3U #EXTINF:577,Franz Schubert (1797-1828) - Symphony No 1 in D, D 82 -1) Adagio - Allegro vivace http://192.168.168.20/mythweb/music/stream?i=1 #EXTINF:467,Franz Schubert (1797-1828) - Symphony No 1 in D, D 82 -2) Andante http://192.168.168.20/mythweb/music/stream?i=2 #EXTINF:369,Franz Schubert (1797-1828) - Symphony No 1 in D, D 82 -3) Menuetto, Allegretto http://192.168.168.20/mythweb/music/stream?i=3 #EXTINF:355,Franz Schubert (1797-1828) - Symphony No 1 in D, D 82 -4) Allegro vivace http://192.168.168.20/mythweb/music/stream?i=4 #EXTINF:635,Franz Schubert (1797-1828) - Symphony No 2 in B flat, D 125 -1) Largo, Allegro vivace http://192.168.168.20/mythweb/music/stream?i=5 #EXTINF:517,Franz Schubert (1797-1828) - Symphony No 2 in B flat, D 125 -2) Andante, Variationen I-V http://192.168.168.20/mythweb/music/stream?i=6 #EXTINF:245,Franz Schubert (1797-1828) - Symphony No 2 in B flat, D 125 -3) Menuetto, Allegro vivace, Trio http://192.168.168.20/mythweb/music/stream?i=7 #EXTINF:355,Franz Schubert (1797-1828) - Symphony No 2 in B flat, D 125 -4) Presto vivace http://192.168.168.20/mythweb/music/stream?i=8

Unfortunately, nothing happens in WinAmp? with a URL such as: http://192.168.168.20/mythweb/music/stream?i=1

I cannot find any instructions that touch on this topic. It's clearly a configuration issue in PHP and the correct directory where the music exists is not being resolved.

I have the mythweb under: /var/www/localhost/htdocs/mythweb I have the music under: /var/mythtv/music

example: localhost mythweb # ls /var/mythtv/music/ Franz Schubert (1797-1828) localhost mythweb #

Change History (3)

comment:1 Changed 11 years ago by stuartm

Component: MythTV - GeneralPlugin - MythWeb
Status: newinfoneeded_new

Please set an appropriate component and version when creating tickets to ensure they are not overlooked.

This reads more like a support request than a bug report?

comment:2 Changed 11 years ago by John L. Poole <jlpoole@…>

Sorry, the component selections escaped me.

localhost mythweb # eix -I myth [I] media-plugins/mythmusic

Installed versions: 0.21_p17821!s(23:18:01 10/18/09)(mmx -aac -cdr -debug -fftw -libvisual -opengl -sdl)

[I] media-tv/mythtv

Installed versions: 0.21_p19961-r2(16:56:13 10/18/09)(mmx perl python video_cards_via -aac -alsa -altivec -autostart -debug -directv -dvb -dvd -fftw -ieee1394 -jack -lcd -lirc -opengl -video_cards_nvidia -xvmc)

[I] www-apps/mythweb

Installed versions: 0.21_p17573(0.21_p17573)(22:40:02 10/18/09)(-vhosts)

[I] x11-themes/mythtv-themes

Installed versions: 0.21_p16505(16:56:21 10/18/09)

comment:3 Changed 11 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

.22 will be released in the next several days and we are no longer fielding bug reports for .21. Please check with .22 upon release and if the issue persists, open a new ticket (though to be honest, this sounds like a job for the users list, and not a bug).

Note: See TracTickets for help on using tickets.