Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#7381 closed defect (fixed)

MythTV segfaults when you enter livetv with a HD-PVR

Reported by: danielk Owned by: Janne Grunau
Priority: blocker Milestone: 0.22
Component: MythTV - General Version: head
Severity: high Keywords:
Cc: Ticket locked: yes

Description

Due to the large a/v sync discrepancy between audio and video in these recordings we attempt to read packets which have not been recorded yet. The backtrace is here: http://pastebin.ca/1630300

If you patch for the segfault using janne's patch: http://pastebin.ca/1630316 then you instead get stuck in an infinite loop.

Somehow NuppelVideoPlayer? needs to make sure we don't read past the end of the file by taking the hidden frames in avformatdecoder's video queue into account.

Attachments (1)

t7381_bufferedframecount.diff (1.8 KB) - added by Janne Grunau 10 years ago.

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by Janne Grunau

comment:1 Changed 10 years ago by olejl77@…

I opened the ticket #7403, and it was closed due to being a duplicate of this ticket. I applied the patch above, but it didn't solve my problem. The system still crashes (even more frequent it seems). I have the gdb backtrace and frontend log if it is of any help.

comment:2 Changed 10 years ago by bradley.kite@…

Hi

I too have been testing the above patch.

Initially, it seemed to work quite well but that was just coincidence as I am still seeing the crashes.

Is there any way to play back under valgrind (some special compile options, perhaps?) as so far, playback under valgrind is awefully slow/jumpy, despite only using around 40% CPU.

I figured that valgrind may be able to provide some more useful info to help solve this, but maybe (on my system any way) it is just not fast enough.

Regards -- Brad.

comment:3 Changed 9 years ago by mythtv@…

I upgraded to 0.22 last week and since that my frontend segfaults in livetv after a couple of minutes. My setup is 2 DVB-C cards in backend and separate diskless frontend.

However, it seems to work if I schedule the show I want to see and watch it through recordings live.

comment:4 Changed 9 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [22623]) Fix a segfault in libavformat that appears to be triggered by an AC3 decoding error. What the AC3 decoding error is triggered by is still unknown, but it may be in either our RingBuffer? or AVFormatDecoder. This patch just fixes the segfault while we investigate further into the AC3 decoding error.

Closes #7381 since this fixes the segfault the ticket was created for. We can open another non-blocker ticket for the AC3 issue.

comment:5 Changed 9 years ago by cpinkham

(In [22624]) Merge over [22623] from trunk. References #7381.

Fix a segfault in libavformat that appears to be triggered by an AC3 decoding error. What the AC3 decoding error is triggered by is still unknown, but it may be in either our RingBuffer? or AVFormatDecoder. This patch just fixes the segfault while we investigate further into the AC3 decoding error.

comment:6 in reply to:  3 ; Changed 9 years ago by anonymous

Replying to mythtv@…:

I upgraded to 0.22 last week and since that my frontend segfaults in livetv after a couple of minutes. My setup is 2 DVB-C cards in backend and separate diskless frontend.

However, it seems to work if I schedule the show I want to see and watch it through recordings live.

I'm having the exakt same problem but i have 2 DVB-H cards. Is there any ticket for this? [47670.138598] mythfrontend.re[4405]: segfault at 560065 ip 01cdbb4b sp ace4fe00 error 7 in libQtCore.so.4.5.2[1c92000+22b000]

comment:7 Changed 9 years ago by anonymous

DVB-T i mean!

comment:8 in reply to:  6 ; Changed 9 years ago by mythtv@…

Replying to anonymous:

I'm having the exakt same problem but i have 2 DVB-H cards. Is there any ticket for this? [47670.138598] mythfrontend.re[4405]: segfault at 560065 ip 01cdbb4b sp ace4fe00 error 7 in libQtCore.so.4.5.2[1c92000+22b000]

Mine did segfault in libc.so IIRC. I switched from opengl to qt painter and seems like it works now. So I guess my problem is not related to this ticket.

Have started to wonder if it could be because I run 32 bit system as I have had much problems with -fPIC -DPIC flags too. Did see a ticket for this but the trac search function is not available anymore so cant find it now.

comment:9 in reply to:  8 Changed 9 years ago by anonymous

Replying to mythtv@…:

Replying to anonymous:

I'm having the exakt same problem but i have 2 DVB-H cards. Is there any ticket for this? [47670.138598] mythfrontend.re[4405]: segfault at 560065 ip 01cdbb4b sp ace4fe00 error 7 in libQtCore.so.4.5.2[1c92000+22b000]

Mine did segfault in libc.so IIRC. I switched from opengl to qt painter and seems like it works now. So I guess my problem is not related to this ticket.

Have started to wonder if it could be because I run 32 bit system as I have had much problems with -fPIC -DPIC flags too. Did see a ticket for this but the trac search function is not available anymore so cant find it now.

I have segfaults whatever i shoose. opengl or qt does not matter. Have seen both libc.so and libQtCore.so. Using Mythbuntu 9.10 and the repo from avenard. Got 0.22.0-fixes22653 today.

comment:10 Changed 9 years ago by danielk

Ticket locked: set
Note: See TracTickets for help on using tickets.