Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7382 closed defect (fixed)

MythTV can dies when you attempt to upgrade from a default install 0.21 to 0.22

Reported by: danielk Owned by: Isaac Richards
Priority: blocker Milestone: 0.22
Component: MythTV - General Version: 0.22rc1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythTV can dies when you attempt to upgrade from a default install 0.21 to 0.22 if you don't install the extra themes. G.A.N.T was the default in the last release, but is now an extra theme.

The problem is that the Theme fallback code does not work if your theme exists but is incompatible with MythTV 0.22.

Change History (9)

comment:1 Changed 10 years ago by sphery

This will require backporting either [22542] (use gContext->SaveSetting?() to write the fallback theme, Terra, to the database--which will cause a clear cache) or [22544] (check settings overrides in MythDB::GetSetting?()) or explicitly calling MythDB::ClearSettingsCache?() from MythDB::OverrideSettingForSession?(). Once that's done, we always get a valid Theme; however, we still need to fix the "QPainter: Painter not active" errors which prevent drawing the theme properly (showing which button is selected) that occur when the theme is changed late in the initialization process.

comment:2 Changed 10 years ago by sphery

(In [22586]) Fix theme reloading and resetting in mythfrontend with painting fixes found by Chris Pinkham. Refs #7382.

comment:3 Changed 10 years ago by sphery

(In [22587]) Use a define for the DEFAULT_UI_THEME rather than scattering the literal theme name throughout the code. Refs #7382.

comment:4 Changed 10 years ago by sphery

(In [22588]) Fix theme reloading and resetting in mythfrontend for -fixes. Refs #7382.

Backports [22544], [22586], and [22587] from trunk. Also backports all of [22542] except the change from OverrideSettingForSession?() to SaveSetting?() (which I'll be reverting from trunk, as it's no longer required).

comment:5 Changed 10 years ago by sphery

(In [22591]) Add a capability for mythtv-setup to fall back to a default UI theme if the specified UI theme is invalid. This rearranges mythtv-setup's UI setup to be very similar to mythfrontend's. Refs #7382.

comment:6 Changed 10 years ago by sphery

Resolution: fixed
Status: newclosed

(In [22592]) Add a capability for mythtv-setup to fall back to a default UI theme if the specified UI theme is invalid. Backports [22591] from trunk. Fixes #7382.

comment:7 Changed 10 years ago by sphery

(In [22593]) Allow fallback to MythCenter?-wide if Terra is missing. Previously, the fallback was only used if the default UI theme was and incompatible version. Refs #7382.

comment:8 Changed 10 years ago by sphery

(In [22594]) Allow fallback to MythCenter?-wide if Terra is missing. Backports [22593] from trunk. Refs #7382.

comment:9 Changed 10 years ago by sphery

(In [22771]) Refs #7382. Fix UI theme and OSD theme changes due to broken/missing themes to use overrides rather than changing the database value. Backports [22589] from trunk.

Note: See TracTickets for help on using tickets.